Touch Interface Thumbsticks has weak detection?


I am curious if anyone else is experiencing this issue. But i have noticed that the analog sticks sometime do not register that they are being touched.

When i set my interface to a custom HUD button interface, then touch events fire a lot more consistently as opposed to using the thumbsticks.

At times you can press directly on a thumbstick which then does nothing. You have to let go and at times repeat the process up to 4 times before it registers that is being touched.

Howdy Crocopede,

Thanks for your report on the Touch Interface. What device are you currently using to deploy your project to? Also, Have you altered any of the Default virtual Joysticks values in the Editor?

Any additional information on this issue would be greatly appreciated.

Thanks and have a great day!


Apologies for the lack of information.
I am deploying to iphone 5c. The only changes made was i copied the touch interface from the engine folder into my own game folder.

After i disabled the reset time to keep the thumbsticks in place in works a little better.

But i have noticed in some cases if you press the thumbstick and move it to the far right and keep it there… it will sometimes disengage as if you stopped touching the screen.

I can only assume this is either due to a problem with the touch interface, or it could also be a problem with my touch events causing an override of sorts for the interface.

I think the easiest way to try and reproduce the issue is to touch the left thumbstick and move it far right towards center of the screen. Then keep your finger there.

Occasionally it would suddenly behave as if you left your finger from the screen.
It could take a few tries.

If this does not happen for you guys then i think it might be the way i handle touch events in my blueprints.

Hey Crocopede,

I has just tried to repro this issue by switching the reset time to zero and then deploying the project to a iPhone 5c, but have be unsuccessful. It may be a possibility that the way you have it setup could be causing the issue.

I know, since i am helping you with another issue, that you are downloading the new 4.5 release of UE4. I would recommend that you give it a try and see if this issue is still occurring.


Hi Sean.

All good.

I think close this one. Or mark as answered.
Thanks again for having a look and letting me know. I will change my touch interface a little.

I think the most likely cause is that i have events that check if you are touching, or swiping or pinching or zooming.

I believe they might at times overwrite the thumbsticks.
Because its not possible to do a swipe while a thumbstick is being used. But at other times a slight touch would register as a swipe that then disables the thumbsticks. Conflicting with each other.

Thanks again.

Crocopede,сan you show in detail how you solved this problem?