Total instablity from 4.5 and up

Unreal Engine 4.4 was solid for me. I had absolutely no graphic lag, no selection issues, everything was placed and worked as it is suppose to. Then 4.5 came out and I started working with it. Then 4.6 (which I was grateful for because 4.5 was totally unstable). Now there will plenty of defense about me saying this so let me make something clear. My machines are free from malware (seeing as how when I was a kid a was a pretty hardcore hacker then became a Network Security Admin and Penetration tester who is a programmer before I started making video games for a living and I also worked for Microsoft as a programmer.) I know what I am doing. My machines are clean, they do no run unneeded **** AND I turn off a lot of windows services that are unneeded while doing game development and 3d. I have a quadcore 4mhz with 8 gigs of ram and 2 gigs of vid ram… This should be able to run a map with a landscape (that is flat) and one box without issue.

BUT NO! due to graphic and memory lag (I also have vulcan gaming ram which is very fast and a fast hard drive) the toolset randomly re-selects geometry and meshs after a freeze lag. ALSO I have submitted about 10 crash reports for attempting to move content out of the root game content directory into sub directories because importing outside of the content directory messes the assets up. These are simple basic programming issues that have obviously been totally over looked (I would not be surprised and even expect that you over utilize garbage collection). Don’t get me wrong your code is very clean but engine performance leaves a lot to be desired. Like I said these issues at the end of a very long line of issues where just adding a new floor and windows (using subtractive boxes and the pillar frame from the props in the starter content) It caused a ton of issues with things becoming unselected. What should have taken me about 5 minutes made me rage quit at about 15.

Come on before you add more android support or IOS support how bout you fine tune the toolset?

Here is a picture of the CPU usage that bounces all over the place constantly…

You shouldn’t be having as serious of problems like that, though your CPU isn’t particularly powerful. Any problems that you can reproduce consistently make sure you post to the Answerhub because that’s where they can keep track of those things more easily. If it’s a big enough issue, then you can try going back to the version 4.4 that worked well enough until there’s a fix.

I actually tried that and sadly it is having issues as well. Today I had to stop work because I placed in a road spline and then decided to remove it opting to only use road splines for finite situations (IE. a turn or going up a hill) the spline tool froze up the editor… I am thinking of uninstalling and reinstalling but I will post in the answer forum first.

If it’s happening now on old versions that used to work, perhaps there’s something that caused the problem that’s not the actual editor itself.

Hi Drixil,

Can you post your dxdiag? Additionally, have you reported your crashes and errors on the answerhub at If not, please make an individual post for each different crash and error, in the crash posts, include your crash logs, callstack, dxdiag, and any reproduction steps that could help us to recreate this on our end. For posts regarding non-crash errors, please include your dxdiag as well as reproduction steps to recreate the error on our end. This will help us to better assist you with these potential bugs.

I didnt read the thread but
“Total instablity from 4.5 and up”

I agree totally, I couldnt agree more.
Please face the truth Epic Developers.

Hi caner_ozdemir,

What specific areas are you experiencing instability in? Have you posted your bugs/crashes/performance errors on the answerhub? This is the best choice when having errors as we focus on bugs/crashes and installation errors on the answerhub, so posting there is a great way to get your posts noticed. Please post your errors there at so we can better assist you.