Download

TopDownView & Click to Move: Input

Hello!

I am using the click to move, top down view project. However, if I add an input, for example Shift, to change the walk speed of the character (walk -> run) for some reason, if the character is already moving it stops right after I press Shift (key). Is there a way that when I press shift the player keeps moving? I am controlling this in the PlayerController, ofcourse.

This also happens with TAB. when I click tab, it seems like the target of the window changes (well, of the hud) like targeting the Canvas Panel (I can see a border pop up). it also kinda stops the character (I need to reclick so it can continue)

Regards!

Can you post an image of the relevant blueprint, I can’t think why that would happen.

Tab switches the focus to the next widget in UMG, you can disable the border in Project Settings>Engine>User Interface and change the Render Focus Rule under Focus, to “Never”.

Also note that if your HUD should never have user focus, you can uncheck “Is Focusable” in the canvas panel properties of that widget.

a739845e87463f7aa5f707bf345ac574cc18f00b.png

Attached is theblueprint (Playercontroller). I modified the setting as you said and now it wont show the border lines when pressing tab. However I can note that after hitting Tab (a new animation comes up, a Combat Animation… from normal animation → combat animation) it kinda “lags”. I guess its because even though its not showing the borders, it might be going through the widgets invisible (since its not showing the border anymore)-

the movement thing when pressing shift seemed to be fixed aswell. Just having troubles with the tab thingy [still]

REgards and thanks!

Edit: if I change the input from TAB to another, lets say “Q”, it works fine (without the laggy thing). Should I go over all widgets and remove is focusable?

Yep, it sounds like your user interface has focus when it shouldn’t, try using the Set Input Mode Game and UI node in your playercontroller, if you want to be able to interact with both. There#s also nodes for set game mode only, and set UI only, which may be of use depending on how you want it to work.

fixed! all solved! Thanks Mosel3y!:rolleyes: