Download

Top down template bug after Set Input Mode Game Only?

Hi, I’ve been playing out with the Top Down template, and apparently if you set the Input Mode to Game Only, the click-to-move will stop working correctly. In fact, all Left Mouse Clicks will start working incorrectly, game won’t register most of them.

Any ideas what could be causing this?

Would be nice to have a screenshot of the input config in the project settings and the input blueprint.

never mind, this is a well known issue, as seen here:

and there’s a free solution on marketplace here:

Turns out the fix above didn’t fix all the issues that “Set Input Mode Game And UI” causes.

if you want to replicate it, it’s really simple, create a top-down template and add this to the character blueprint:

When you open it, click to move works fine. But as you press X to change input mode, now holding left mouse button and dragging around to move won’t really move the gizmo, it starts stuttering in place.

Pressing X again to change input mode back won’t fix this weird behavior. Even with the supposed Mouse Capture mode fix.

Any ideas?

what is the default input mode when game starts? I suppose it’s not exactly “Game Only” or it would go back to normal behavior when I change it back to it

huh. this annoyed the hell out of me, been trying to solve it for a few days, and just realized all I had to do was to uncheck “hide cursor during capture” from the “set input mode” node. welp

image