Tooltips in Editor not at Mouse Cursor Position

I am running Unreal Edtior 4.7.6 on a Windows 8.1 machine in a multi-monitor setup. When I hover over editor widgets which are in a window located on the main screen, then the tooltip correctly shows up at the current mouse cursor position:


However, on an Editor window located on the second screen, when I hover over a widget the tooltip is shown far right from the current mouse cursor positioon. In this screenshot the cursor is at left BP node, but the tooltip is shown to the right of it:

Is this a bug in the Editor, or can I change that behaviour somehow?

Update 1: It seems this Editor behaviour only occurs if I have the “great” Windows 8.1 screen auto-scaling feature enable in Windows control panel. However if I enable the Windows setting to choose one scaling level for all my displays (again via control panel), then all tooltips in the UE4 Editor are fine. (Unfortunately that is not an option for me, because then the scaling on my main notebook monitor is way to small to read the UE4 Editor font.)

Update 2: It seems not only the tooltips are affected by that Windows auto-scaling feature. Also when I run the game from the Edtior in a new window, then that window is not centered on the (second) screen, but again to much right, so that half of the window is off screen.

Thanks for your reply, . I am pretty sure it is because of this Windows scaling feature. Because when I disable it and set no scaling, then the tooltips appear at the correct location in UE4 editor.

It seems to be very easily reproducible though, so you should be able to see exactly what I mean when you use scaling in Windows 8.1.


Hi Haimat,

I just wanted to let you know that I’m waiting for our Compatibility Lab to become available to test this. If you have any other info on the bug, feel free to respond here.


Follow up question. Does it only occur on the secondary monitor or have you tried turning on scaling with the primary as well? This might save me some time as the compat machines only have one monitor.


The problem occured only with the 2nd monitor in my case. I am not sure how exactly Windows 8.1 calcualtes how to scale each monitor, as unfortunately you cannot set how to scale separately for each monitor (only on or off for all of them).

But it’s easy to reproduce if you simply attach a monitor to a notebook, if both have a different resolution and DPI values.

Hi haimat,

I’m going to be marking this as answered because we’ve been unable to reproduce in house and appears to be an unavoidable side effect of the scaling features on such a small screen.


Well, technically it is not answered :slight_smile:

Is this a show stopper for your work in the editor? If so, I can try to escalate this again.

EDIT: I’m attempting to track down another notebook to see if we can get a repro.

Thanks for your response, . Well it is not a show stopper, as I have managed to work around that issue via some Windows settings …

Can you tell/show me what your settings are for scaling in the display panel as well as your screen resolutions? I’m still having trouble reproducing this with one of our laptops.

So as said the problem was with the Windows 8.1 scaling feature. When I let Windows auto-scale both the notebook screen as well as the attached monitor, then the problem occured as described in my OP. Turning the feature off in Windows led to the problem that my noteobook screeen is far to small for a resolution of 1920x1080, so that I could hardly read any text on that screen (e.g. in UE edtior).

What I did now is to turn of scaling feature (“Let me choose one scaling level for all my displays” option in Windows display settings), and decrease the resolution on my notebook screen. Now the tooltips appear on the right spot within UE edtor, and I can read the text on the notebook screen due to the smaller resolution.

When I attach a low resolution second display to my 4k laptop the editor tool tips are offset to the left, 1/2 their correct distance. The tool tips themselves are extremely small, characters just above the size of a period. The scaling is definitely coming from the low resolution second monitor. Windows 10. Tested a bit more and the scaling event happens only when a form from Unreal becomes resident on the second monitor. To clarify, in my case my main display is the one being scewed.

This is still occurring in 4.16.2. Two monitors, both 4k, windows 10, one at 200%, one at 125%. Primary monitor is 125% and that is where the main UE4 window is running and I have the ‘output’ window undocked and on the other monitor. All hover-text in the blueprint editor is left and down from where it should be. If I set all monitors to the same scaling % then it works fine.
ALSO, I have found that if i open the ‘widget reflector’ and merely leave it on-screen (not minimized, not docked - separate window, on the SAME monitor as UE) then the hover-text in the blueprint editor is correct. Change that in any way and it is wrong again.

Moving the output window back to docked on the same monitor (without the widget reflector) also ‘works’ but then I’m not getting the advantage of log output on a 2nd monitor.

Also, in this setup, launching in a new-editor-window does the same weirdly-sized resolution and placement unless I configure it to launch small (1280x720).