Download

to rama and others for blueprint plugins

when i download the extra plugins added in “rama’s extra blueprint…” i get this error shown in the image. Is anyone else having this problem?a44f0550837d3951011874b24bc18e34a65070ad.jpeg
So i then checked it off as being active and it doesn’t find anything even with context sensitive turned off.

You’re using the wrong version of the engine. The plugin is probably compatible with 4.3 while you are using a different version I suppose.

I’ve had this problem as well. First, make sure you’re using the right version plugin for the engine. If it is correct and the problem persists, you may have to recompile your project through Visual Studio with the plugin enabled. Fixed it for me.

@Malospam

The most likely case is what Fuchs said, make sure you are using the installer version of 4.3

There is a known issue where plugins dont work unless your project is C++ based, at least for packaged games.

If you want to use my plugin in a packaged game you will need to make it C++ based and install Visual Studio

This is something Epic needs to fix!

You can add your voice to have Epic resolves this here:

https://answers.unrealengine.com/questions/72781/unable-to-run-community-plugins-when-packaged.html


@Phystrontium

Congrats on your first post!

:)

Rama

Yeah this bit me the other day - I went to go launch a standalone version of the game to see if performance was better, and the Hydra plugin failed to load for the reason that Rama points out. Would be annoying to disable it since there are references to its classes, too. D’oh.

Strange huh? I hope Epic sees our posts about this!

Rama

I went ahead and replied on the AnswerHub as well. I’ve love to get this sorted so I don’t have to go messing around with a C++ build (which isn’t that big a deal, but it definitely impedes smooth workflow).

I have the newest version but I’m not touching Visual studio or anything C++, I only use blueprints. Well that sucks!

My project is also only using Blueprints. But, (unless there’s another way) if you really want to use the plugins, all you need to do is go under File -> Add Code to Project -> Next -> Create Class. Then open it in Visual Studio and click Build. When it’s done you shouldn’t have to ever touch C++ / VS again. Doing this allowed me to use the plugins for a Blueprint-only based project after I had the same error.

I’m sorry this is catching so many people out. We’ve have basic support for plugins since 4.0, but it’s still not at a level that I’m comfortable advocating it for widespread use. There are lots of subtle gotchas, and not being able to use them in content-only projects is an ugly limitation.

As I mentioned on this thread, I’m going to try to focus on it for the 4.5 release, and I hope I’ll be able to give you some better news then!

Yes, plugin support has sort of been in a beta state since launch, while we work on spinning up the Marketplace. For Blueprint-only projects, we’ve spent many hours discussing the best approach to supporting this and as Ben said, we think we have a good plan to finally solve this for 4.5.

This is an excellent workaround to use for now, if anyone else is having this problem. The only real downside is that you need to have the compiler installed, and also you’ll need to take care when upgrading between engine versions (make sure to recompile your game module before loading up the editor after upgrading.)

Remember you only need to deal with this for packaged Blueprint-only projects that use code-based plugins, including projects that are deployed to a mobile device. You can develop your Blueprint only game using plugins on Windows and Mac, and you can use the ‘Play in Standalone Game’ to preview your Blueprint-only game (with plugins enabled) on those platforms.

–Mike