Download

to developers, ue 4.14 crashes! - Error: 0x887A0006 - 'HUNG'

Are you sure that you’ve correctly tried all of the work arounds? If you set it into forward rendering mode, you’d have to restart the editor because it will have to recompile every single shader in your game and usually takes forever and a day on that first relaunch; after you change to FR. I’m around 95% sure you won’t have any more crashes like that.

Though while I’m here, I may as well complain some more about getting these crashes left and right. Even though it crashes all the time, I still stay in deferred rendering because I need it for effects and things that aren’t supported in forward rendering. For me, it’s always the DXGI removed error and never the hung error. I’m not going to submit 30 error reports per day, so please don’t ask for anymore of them. A while back, I sifted through the source code to see the errors and if I recall correctly, it was being removed due to an unknown error, so it defaults to the “removed” error in those cases. I’d have to double check though.

My guess is that it has to be some kind of low level interfacing issue between the deferred rendering engine(mostly directx, but still crashes in opengl here and there), the directx/ogl api and the video card drivers. It started around 4.12 or 4.13 because before that, I had never once had a crash like that. I remember testing it out where I still had the previous engine version installed. I couldn’t get it to crash no matter how hard I tried and yet the later version would crash on demand; every time. Therefore, I’m almost positive that the problem lies with the unreal engine and I doubt that nvidia/amd drivers are to blame because those drivers were a variable that was held constant.

Just a quick question. Has anyone experienced this crash in a packaged build? I’ve been using the UE4 Editor (4.15.3) without any crashes, yet I’ve been getting more and more reports of the game crashing with this error report:

I’m just wondering if this crash is related to the editor only or if this also affects a packaged build?
I can run my game fine and it seems that the affected GPU cards correspond with my own reports.

Hi all,

Since the release of drivers 382.33 on the 22nd of May, several Unreal Engine 4 games have been affected by heavy system crashes that make playing such games impossible.

The issue I’m talking about is this one: Unreal Engine Issues and Bug Tracker (UE-42280)

The problem persists even after the release of the drivers 382.53 on the 9th of June.

The last working drivers seem to be 382.05 released on 4th of May.

As such, I would like to receive all possible information on this issue, on what is causing it and how to circumvent it if possible. Even more important, I would like to know if Epic Games is actively working with Nvidia to solve this issue at its source (like AMD should be doing, as stated here: https://community.amd.com/message/2802464 )

Thanks a lot!

Here’s an open list of games experiencing (allegedly) the same problem:

Dead by Daylight

https://steamcommunity.com/app/381210/discussions/7/135509472107458932/?ctp=7

Downward (Our Game)

EVERSPACE

Friday The 13th - The Game

Little Nightmares

Playerunknown’s Battlegrounds

http://forums.playbattlegrounds.com/topic/28103-unreal-engine-is-exiting-due-to-d3d-device-being-lost-error-0x887a0006/

TEKKEN 7

I guess this answers my question…

Yeah, I’ll correct myself and say that forward renderer did fix the crashes, but it’s the only thing that works, and I’m not sure forward rendering is right for my project. I was a bit afraid of switching because I haven’t seen a proper list of what deferred vs forward entails (advantages/disadvantages) and what will break in my project.

Yeah, it’s really terrible; in it’s present state. As much as I love this engine, this persistent bug has made me seriously contemplate leaving for Unity. It’s been waaaaaaaaay more than enough time for them to tackle it. No joke, it’s been an issue for over seven months now… You’d think that a frequent editor crash, that hinders and almost makes it impossible to finish/publish a title, would be incentive enough for them to fix it… Because you know, developers publishing titles=income for epic. Apparently, it’s not affecting enough people to make it a priority though.

But I’ll end my disgruntled rant there and go back to modelling asset number 300000000 while I wait for them to fix the editor/engine lol…

Hi Guys,

Unfortunately, i have met this issue today. It’s horrible. UE 4.16.1. Geforce 560Ti. Probably driver was updated in background. I am downloading 382.05 and will make clean reinstall. Will notify about progress…

Hi Guys again !

I wasted yesterday trying to fix this issue. Finally i did it!

I tried the all medicine described above. I updated UE for the latest official version, clear installed several versions of graphics card drivers(latest, May 2017, February 2017), played with forward rendering, etc - nothing helped. I have been dancing with tambourine around UE the whole day. Then, i remembered that i turned OF real time rendering in the editor viewport since i added dynamic sky into my project and my head started spinning. I turned it ON again and wow bingo it fixed it to me !

ue4_fix.jpg

I realized that the issue is related on some subset of old Nvidia cards, i guess it was nothing to drivers but under special circumstances UE4 editor produce card’s wrong behavior. Despite of this - a game compiled in shipping configuration works great on the same PC.

I am a C++ guy so when i will have free time i will dig it deeper.

Cheers!

It will seem like that is a fix to the problem, but then it will persist. There have been many times that I’ve thought I got rid of it, but then it comes back a few hours later. Like I said earlier, it has to be some kind of glitch in the code that interfaces the engine to the graphics API. It’s not a driver issue or a directx issue because I’ve never seen these problems in any other 3d application at all. Not once, in decades of gaming/3d modelling/etc, have I ever gotten a dxgi hung or removed crash error. Hundreds of games and applications, but it’s only ever happened with the Unreal Editor…

The crash is happening in packaged games on AMD cards as well. Also, it started happening with 4.14 so it’s definitely something that was changed/added to UE4 back then and not simply bad drivers or older GPUs.

Still not a single peep on this issue, still in the 4.17 preview it still shows as unresolved, is this ever going to get fixed? I mean it only has the most votes of all issues, can you all just not fix it?

Hi all.

Although this has proven to be a challenging and elusive issue, we have been continuing to work on it and have just submitted a few separate code changes that we are optimistic will help. These changes will be making it into 4.17 Preview 2, and we will be closely watching for feedback and crash data once it goes live. Because this is a widely ranging issue, with no single repro case and only a few repro cases we have identified in-house, we cannot confidently say the issue is “fixed”, and so the Jira ticket for the issue remains marked as Unresolved. We are hoping for a significant reduction in the frequency of these crashes with the changes that have been made, but we will not know for certain until a large userbase has tested. So please, encourage others to test the Preview, and always remember to submit your crash reports.

Thank you

edit: the Jira has now been marked as ‘Fixed’, but we are still watching for lingering cases. It is important to recognize that some D3D HUNG crashes are still expected for low spec hardware, but we are optimistic that other cases may be resolved.

Hi, Stephen!

Could you pleeeease make happen that this fixes will be released with 4.16.3?
We just announce our game to be released on 1st August and all QA and bugs fixes was already finished. So even if 4.17 will be released before 1st august we will be not able to retest full game. We suffer from this problem a lot, we seeing hangs with NVidia and AMD cards so potentialy it could be big loss for us…

Thanks,

Hi,
I have Nvidia GTX 680M. (Windows7x64 on an MSI gaming laptop GT70 0NE) I found the following worked for me:
Enduring lots of crashing! I ended up reverting my Geforce drivers from the latest vesion 382.53, to the now year-old older 368.81 Worked ! (Release Date: 2016.7.14) .
But then I discovered this was working very slow navigating and causing menu artifacts in Blender and was slower than it was using the newer drivers (though reliable) in UE4
I found the answer in a couple more steps and everything is sweet ! I used the Nvidia Control Panel:
set:

  • Manage 3D settings > Global Settings > Power management mode = Prefer maximum performance and
  • Manage 3D settings > Program Settings > UE4 to use “High-performance NVIDIA processor”

I turn the Content Browsers, real-time thumbnails off on most projects, a habit from the crashing days and I also have kept a mod in the Registry, that did not work alone and I doubt it makes a difference, but here it is:

  • First navigate the key path HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\GraphicsDrivers , Right click on GraphicsDrivers and go to new> DWORD (32 bit) value
  • You will see a new key appear make sure to name it “TdrDelay”, Right click it and select “modify”, Under Value data enter 10 (decimal)

As I said everything is now so, soooo sweet!

Edit 07.24.2017 : 3 days of heavy use and it simply does not crash at all. Heartened by how stable it is I let several programs run concurrently such as: a couple of cloud syncs, Firefox including streaming Youtube tutorials, Thunderbird, Blender, OpenOffice, PDF-Viewer and several background services (antivirus, Afterburner, etc)… all at once. Great.


So plenty reports by Nvidia GTX users crashing their games and editors, are suprising for a game engine, by nature dependant on good graphics card. On my end I used the editor, I wasn’t running a packaged game, I wonder if it’s the same on the gamers’ end? I was even more surprised that unlike the plenty error complaints, there is little record of cures. I tried several proposed fixes. Unfortunately due to haste and frustration, I have not kept a good record. I remember VAQUELY that among things are tried are a few switches for the engine regarding opengl, dx12 (both of which were not supported for my gpu), turning of the content browser thumbnails and somekind of graphics card latency value editing the Registry. None worked.
Here is the most extensive reporting of problems and solutions, that I found helpful - I tried most suggested solutions before switching to an older driver.

How I Can Set GRHINeedsExtraDeletionLatency=1
Should I write as cmd when engine start or what

For me this issue is caused by having too much load on startup. I use level streaming and when I enable one of the levels and leave it on it crashes. I think it’s related to cache and the processor. I have 4gb vram and 32gm ram and neither are stressed to 100%. It’s definitely the initial load size causing me this issue, disable the level when closing and re-enable it upon opening otherwise it locks the project and won’t open. Might be the lightmaps or the shaders, either way I disable the biggest levels before closing down.

Never answered? Have the same question. Sigh…

I’m not a programmer, but I believe this is a source code change to /Engine/Source/Runtime/Windows/D3D11HRI/Private/D3D11Device.cpp, where you add GRHINeedsExtraDeletionLatency=true to the end of the FD3D11DynamicRHI constructor.

For my long time experiencing errors like this, , believeme,pull out your RAM from you computer, use some alcohol to clean & put it back (not wet), , do same for GPU, you errors will dissapear 99.9&% . You should take health care for your computer, its a technical organism … In 99 % cases this is error for faulty RAM

Today I got this too :confused:


 Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0006 - 'HUNG')

UE 4.18.2, Computer Zotac, Win 10 pro b16299, 16GB RAM, i7-7700 3,6GHz, GeForce GTX 1080