Download

Tiny animation when importing from Blender - I think I got the solution!

This is a question that pops up a lot and I too was having the problem. I started solving this by renaming the skeleton in Blender to anything but “Armature” (this is suggested a lot). This in fact solves the problem, but if you notice the skeleton in Unreal, a root bone is created with the name of the armature in blender with a scale of 100 (that’s why this fixes the size problem). This will not work if you need root motion on your animations because you cannot animate the skeleton in Blender, only the bones (well, if you are using Actions at least).

I tried something else I read somewhere, that involved changing the scale to 0.01 in the FBX exporter settings, and setting “Import Uniform Scale” to 100.0 in the Unreal importer (without renaming the armature in Blender) This also solves the problem, Unreal does not create a root bone, so your root bone in the armature is the root bone in Unreal, and this allows for root motion. This solution is better then the first, but I was having really strange behaviors with my root motion animations, it looked like the movement was amplified. In this solution, the root node of the skeleton still has a scale of 100.

I then tried a few more things, and I finally reached the solution I think is the correct one.
In Blender, I set the unit scale to 0.01, and changed “Length” to centimeters in the “Scene Properties”. Now, because I changed the scale, I have to model everything at that new scale, so I have to model 100x bigger then I would normally model.
I don’t rename the armature (leave it “Armature”), I don’t change the scale in the FBX exporter (I leave it to 1.0), and I don’t change “Import Uniform Scale” in the unreal importer (I leave it to 1.0).
Now, when I import, I don’t get any warnings (like that annoying import transform warning), the root bone of the skeleton in unreal has a scale of 1.0, the animation size is ok, and root motion is working properly.
A final note: In order for this to work, there can be only one root bone (the hip for instance). So, I removed “Deform” for all IK and pole target bones, and checked “Only Deform Bones” under Armature in the FBX exporter, or else the other annoying error “Only one root bone supported” in the Unreal importer will popup.

I’m just posting this to help others that face this problem.
Please someone correct me if I’m wrong in any of this.

1 Like