Timers do not work in Objects


This bug is actually from 4.17, but still not fixed in 4.18.

Timers do not work inside Objects in blueprints.

To reproduce

  • Create an object class
  • Create event “Init” and connect it with “Set Timer By Function Name”. Make a function with a same name that should be called
  • Construct somewhere an instance of the Object and call “Init” event.

You will see event and timer fires as expected but function, that should be called after timer ends, never called.

This bug also appears in 4.16, but only on the same tick with Construct Object. In order to make timer work in 416, you should construct an Object and after delay call “Init” event.

In 4.17 or 4.18 this method does not make any difference, timers still not work.


Do you have any screenshots that you could provide to give additional information?


Sorry for a delay.
Here it is:


Any news on this? Really critical thing…


Apologies for the delay. Thank you for reporting this issue. I have created a JIRA which you can track here: UE-51011


Interesting, my guess is that Timers aren’t working because UObjects don’t tick.

To get around this, you could create a custom C++ class that implements FTickableGameObject, then base your BP class on that.

Yes, that may be the reason. But timers work well in 4.16.
And I think, that it does not matter, as timers work from Worlds time manager, not objects them selfs.