Timeline wont "Update" a value

Hello all! I am trying to create a recoil like system using blueprints, I am using a add pitch input, and just adding a float value to it for the recoil, but it is too sudden! So I used a timeline to try and update it as the timeline goes, but it wont “update” the value as I have seen it work elsewhere (For instance, it is supposed to make the recoil be lower in the beginning and higher near the end, instead it just seems to be the same high recoil value, which is not what I made the timeline for.) Thanks in advance!

Your Timeline is plugged? (start?)
If Not, is AutoPlay?

How are you playing the Timeline? Some screenshots would help.

Thank you for commenting!
I plugged in InputAction Fire to the Play from Start to play it, I then plugged in my float value to my set blueprint, and plugged in the update to the set blueprint as well.

I will post a screenshot later today as well.

It is plugged in.

does it have a track and keyframes?

I talked about it more to Jacky (Thread below)

Is that float the one you were using before timeline or is it a float track you set in the timeline? You need to set the float value and its curve over time in the timeline then use that float output to set the pitch.

The “floats” are A. The recoil float (used for the actual pitch input) and B. the float that is from the timeline itself (The value(s) from the timeline). And could you please explain more of what you mean by “and its curve”?

Yup, it has a track and key frames with different values.

If you have a float track in Timeline(from 0 to 1 to 0 in 1 second) then you also need another float, which would be 0 to reset the camera, and then animate between your recoil value and 0 using a Lerp node and timeline float for the alpha. Something like this:

Or you can use only the timeline’s float for recoil and setup the curve like the picture below; between 0 to 45(your recoil pitch value) and then back to 0 in 1 second:

Thank you! The 1st Answer worked well (I have not tried the 2nd answer yet), although I did make a edit or two to make it work with my current recoil system, but that was expected.

Turns out this doesn’t work. It still wont update correctly. It does the recoil, but at a much much too low value. And it doesn’t do it for the duration of the time it should.

You need to use the Timeline’s float track as the alpha of the Lerp. Or just plug that float to controller pitch input and get rid of the Lerp.

Thanks! That works.