Timeline Time Issue


I have an issue with the timing of an animation driven by a timeline. I need to move smoothly an object from point A to point B and it works fine, but the timing is not correct. The transform should take 8 seconds, but is done in just 2 seconds. I mean, is smooth and everything, but it’s just too fast. Increasing time in the timeline from 8 to 16 seconds, doesn’t change the timing. Firing the timeline with a Tick Event, didn’t solved the issue.

1 Like

What happens if you plug it to Play from Start instead of Play?

Still 2 seconds from startpoint to end. The distance traveled is right.

You should not fire a timeline from a tick event , but if you have too use “DoOnce” node and reset it when the timeline finished

It isn’t. Is an one time trigger event.

I tried Tick as I thought it could help…

Create a new Timeline if you havent tried that already and see if it does the same.

new timeline from scratch shows same behavior

Try this.

Before starting the timeline, get the world location of the object and store it as variable (Make sure this is called only once, don’t use anything like Tick Evet). After that in your lerp, plug in that variable to “A” and have the destination location to “B”. It should work.

Try my suggestion below my friend, might work.

YES!!! Many thanks!!! Storing the Position first did the job!

Thank you very much everyone for the help…great comm

Thank you! I’ve been looking for this one for a few days, I think it’d be worth updating the documentation to cover this. Because Blueprint traces node connections backwards from a function node (as I understand), any temporal nodes will affect values retrieved.

This was the answer I was looking for!! thanks so much!!