Download

Timeline is not working

Hi,
I am working on animating a window shutter. Each plank of the shutter is a separate mesh. And I run a loop function of open and close the shutter. Everything works fine, if I run it. But they just snap in just one frame where the angle of the shutter plank turns from 0 to 40 degree.

I do not want that. I want the shutters to be slowly turns from 0 to 40 degrees over 2 seconds of time. So, connected the function through the Timeline. But it is not working. I am not sure what is the mistake I did. Can someone please help me to fix this.

When I debug, I see the line connected to the “Update” output node is not firing. So, obviously, the “Timeline” function is not working in this.

Thanks in advance.
Regards,
Siva

Can you show the whole chunk of code?

you need a to connect the shutter angle 1 to the axis you need to rotate.or if the the timeline is 0 -1 value with lerp node before seting the rotation

Are you calling it from the editor or PIE?

U can use actor sequence to animate stuff without code.

Hi, I call it from Sequencer

Hi, even after connecting the shutter angle, it still didn’t work. While debugging, the line that goes out of the “Update” is not turning red at all.

Hi, sorry, can you please enlighten me. I don’t understand.


Here it is

Like this

Also, I see your custom event is ‘run in editor’, which doesn’t use timelines. Timelines only work during gameplay.

So, I cannot use it in Sequencer? Can you please suggest any other method please.

You either have to use editor tick

or record the sequence while the game is playing…

Ok. Thanks. I will try this. If it didn’t work, I will have to do the animation in Blender and import it in to the sequencer.

1 Like

why not use actor sequence? it’s much easier and it’s done visually. it’s under components tab inside an actor. it behaves the same as level sequencer. execpt that u can animate other components like static mesh’s.
Annotation 2021-08-15 233159

i need to mention that bcz this class is experimental i noticed there might be a bug in actor sequence, u can’t rotate or move the object inside viewport once it’s added to the timeline, u need to rotate or move it via the parameters inside timeline. which is odd, hope it gets fixed.

Thanks. Let me try this.

Oh. I understand.