Download

Time Synth Component only working with 90 BPM?

Hello,

I have a time synth component that I’m using to play audio. But I can’t seem to get it to play anything other than 90 BPM. I think I’ve found where this goes wrong, but I’m not exactly sure why…

94d95e98e91b47bfd2ab4f12bd12f4ac375f060c.png
https://forums.unrealengine.com/core/image/gif;base64

Here you can see I’ve set the BPM to 72. This is in “UTimeSynthComponent::SetQuantizationSettings()”. But what’s strange is that “Settings.BeatsPerMinute” is zero! Which shouldn’t be possible with the “FMath::Max()”… it should at least be 1.

369593e12a2128b0e0868fa644f156869b49ba10.png

I’m guessing that since BPM is zero, the system default back to 90 BPM, which causes my track to end prematurely, among other things.

Just wanted to see if anyone else has run into this issue. Not sure why it’s getting set to zero but there must be something odd going on here.

Upon further analysis, it looks like the BPM never updates, it only stays at 90 because that is what I initially set it to. If I try to update the BMP to 72, it stays at the initial value (90 in this case). Not sure why I cannot update BMP…

I’m controlling BPM fine in 4.25.4 by changing quantization settings through BPs, using the timesynth-level in Arthurs audio blueprints