Time dilation on Physics object


I run into a problem with time dilation. I have found and followed this thread:

This function is working perfectly with the player character, but when I try to set the Custom Time dilation on a physics mesh (I mean a static mesh with physics simulation) it doesn’t work. I don’t know if it’s a bug, but I really need an answer for this!

Please help me!


Check this
Time dilation does not work on physic actors, as per UE3, seems like it’s still like this in UE4.

Thank you for your answer, it was very useful!

In case anyone stumbles on this post:
I got around the limitation of physics not being affected by CustomTimeDilation by changing the global time dilation (which affects physics) and counteracting slowed movement on my character by amping up the CustomTimeDilation on them accordingly.

Hop this helps someone!

Would be really cool to have options to have CustomTimeDilation possible for certain actors, also with affecting physical simulations and everything else. The same as global TimeDilation .
It’s needed when only a part of the game should be shown in slow motion.

Anyone knows a workaround for this? Even which some C++ code or small engine code changes perhaps?
I need to make area in the game shown in slow motion, regarding projectiles (projectile momvement component), physic simulations, animations, tick, etc.
Also for physic simulations is important, without it it looks ugly.

As I said, only in specific areas (custom overlap trigger volume)
thanks a lot