Download

Tiled Map edges not lining up. Solutions? (Not using WM)

I’m using world composition to tile together a large map. I’m splitting my heightmap “tiles” via Krita, but when I import the heightmap tiles the edges do not line up.

What are the possible solutions to this problem (without using world machine)?

I figured out my problem (which was actually more than a few problems combined). I was going to delete this, but I’ll “answer” my problem in case anyone else has the same or similar issue.

First I was attempting to slice up a .PNG heightmap (exported from UE4). Loading the png heightmap back into UE4 gave me no issue. I then went into Krita (it’s more or less like a free version of photoshop) and used the split image option to split the image into multiple heightmap tiles. When I would attempt to mass import the tiles through World Composition, it would let me select the tiles, but would give me an error saying something along the lines of “this png file is not grayscaled … you can still import the tiles, but the result may turn out to be something unexpected” … However … the import button was grayed out and wouldn’t let me actually “import” anything. At this point I assumed it was a bug with loading png based heightmap tiles into world composition.

Then I tried using .r16 files instead and the tiles would turn out all spikey and looked more like hellraiser’s face on drugs than a landscape … I played with this for 2 days trying to figure out why the landscape didnt look anything like a landscape. It also didn’t matter how I adjusted the scale of the xy or z axis … even setting z scale to 1 it was still all spikes everywhere.

Just a bit ago I exported a “good” landscape from UE4, then re-imported it and it looked as it should. So it’s not an issue on UE4’s end.
Then I loaded the .r16 file up in Krita, then immediately saved it, then went into UE4 and once again the landscape looked crazy bad.

So at this point I’m assuming either I’m messing up something in Krita that deals with how the .r16 files are saved, or Krita just doesn’t handle .r16 files the way it should … not sure. Mind you .png files work just fine.

Just now I realized that my 505x505 sized .png heightmap needed to be 504x504 before splicing it up into tiles. After I did this, I was able to import the tiles perfectly fine.

The only issue is the landscape tiles don’t line up properly … but that’s easily fixed by using the “smoothing tool” and setting the strength to 0.0

Previously (when I made this post) I was creating an entirely new landscape and loading in a png tile then saving that landscape into the persistant level’s folder so world composition would recognize it as a “tile”. When you try to do it this way you can only edit 1 landscape at a time, but with the tiles mass imported properly they become landscape_proxies which allow you to edit multiple tiles at once.

I case you’re wondering why I would ever need to chop up a 505x505 landscape … I’m making a huge “low poly” world with the landscape scaled up to 2000 on each axis.


In short:

  1. When Mass Importing tiles … make sure they’re the “correct size” or else the “import” button will be grayed out.
  2. Don’t use .r16 files with Krita, use .png files instead (atleast in my case … as I said I might have messed up something in Krita’s options).