Tiled Landscape Missing Textures Problem

Can you please tell me how to fix this? It is driving me mad.

See my youtube video for more details on my setup:

You’ve run out of texture memory. In your material, click on all the textures and ( in the details ), change sampler source to ‘shared: wrap’.

Bro you didn’t even watch the video. I already explained that is not the issue.

Oops sorry :-/, it just happens so much - auto pilot ( gonna watch the vid now )…

No worries dude. Definitely could be some kind of memory issue but at the moment at least internally it only says its using 4/16 texture samplers. 3/16 if i set literally every texture to shared wrap.

Yes that is something i was thinking because the tiles that actually render properly are always seemingly random–then i noticed they are all along the same plane of height… either it only renders the very low sand tiles or the very high mountain tiles. At first i thought it was somehow related to my sand mask, but i don’t think thats the problem, maybe there is some kind of level or world bounds that are restricting the rendering of textures outside of that sphere? Just a guess, no clue if thats even a thing.

And yes, i did mention in the video i already tried clearing the shader cache… I’ve actually done it a good 3 or 4 times since i posted the video, doesn’t really help. Tried updating to the 4.26 preview, didn’t work either. Actually for some reason in 4.26 literally none of my lights are working now but bugs like that are to be expected with unstable preview versions.

thats fair, although maybe its arbitrary to where the actual center of the z axis plane is? The actual world composition itself somehow ended up sunken down super far past the origin, that could be why the tops of the mountains are rendering first. I will try it with a simple material with no bitmaps and see if that still has the issue.

Ok i tried it with a new material with just a plain color vector plugged into the diffuse. It didn’t look like it was going to work, because it looked just like the previous example halfway through compiling shaders. By the end, it actually updated, so i could see the whole thing textured. Actually looks really close to how i wanted it to. But do note that it did render in chunks from the top down… Again, it feels like the compiler is trying to do the same thing for the bitmaps and craps out halfway through and doesn’t ever update again even though it says its still compiling.

I’m going to start adding back in bitmaps and see when i hit a wall. Frustrating as hell Epic leaves the compiler a black box so i can’t debug it when ■■■■ goes wrong. I can’t even manually stop compiling or recompile textures

Ok, no idea basically… But it very definitely is related to height. The two things I’d try, in order of least hassle would be:

  1. Try it with a really simple material and see if that works, then make my way back from that to the current mat.

  2. Clearing the shader cache:

Sorry to not be much help.

I don’t think it’s memory, because then you’d probably get a more random distribution of the problem.

Ok so i tried your idea of starting from scratch and working my way up to test it.
Test 1, i plugged in simple flat colors into the diffuse channel for each of the 4 layers. Success.
Test 2, i plugged 4 diffuse textures in in place of those flat colors. Success.
Test 3, i plugged in 3 heightmaps in and used them for height blending on the diffuse maps. Success.
Test 4, I plugged in my normal maps and used the same height maps for blending. This is when it crapped out on me.

A grand total of 11 texture samplers, far less than the limit of 16, all set to shared wrap.

Note the ostensible number of shaders highlighted below, 2/16.

I guess Epic is satisfied with their developers just plain not being able to use normal maps. How modern of them.

And I assume if you keep normals and reduce use of height ( for instance ), it’s ok. Bit ■■■■…

( just checking it’s not somehow normal related )

Ok so i think i figured out the issue. I had to retry it again with my original material just to test it, because i didn’t believe it could possibly be something that small and stupid, but it was.

Remember that normal map i mentioned in my video? The one i had to manually set from Color sampling to Normal because the system kept interpreting it as a color map every time i imported it? Yeah THAT was it. That was literally the entire problem. I removed it from the chain, i even replaced it with a normal map from one of the other textures, and everything worked fine. I have no clue why this single normal map would cause the entire shader chain to ■■■■ out on me, or why it would render half of the tiles properly before crapping out, or why it would insist on sampling it in color mode even after i manually set it to normal–a single texture map should not ever be enough to cause the entire shader compiler to crash, and if it had, there should definitely be SOME kind of feedback in the console about it. Instead, i got literally no debug information and wasted literal weeks of my life sorting this mess out all over one tiny insignificant Normal map that was temporary and parameterized anyway.

And the worst part is, I’m not even 100% sure this is the culprit. It seems to be working now, but i have no guarantees this issue won’t start up again in the future because i have no way of confirming this is actually why it happened.

Seriously, Epic. Get your ■■■■ together. Literally no other renderer or game engine on the market craps out over a single normal map. This is base level stuff here.

Good you got there :slight_smile:

Yes, I also find when things take a bit of an unusual turn, there’s basically no support out there for it. All you have left is pursuing engine code… :-/

Hey man do you think you can answer some of my other questions? You seem like you know your ■■■■ and there is not a lot of help out there.

Well, I might know. Why not post it and send me a link ( that way other people might know too ).

well, the biggest problem i have been having is this:

I made a youtube video on it here:

And the other problem i am trying to fix is more just finding a workaround for the lack of a proper “Add Component From Class” feature

Ok, so far looked at the character orientation vid. No idea I’m afraid, not a big character user. I will say though, that I often find stuff in the engine that doesn’t work the way I think it should, and I just find the best workaround / other way of doing it.

It’s much easier than telepathically trying to make Epic correct engine inconsistencies…

Ok well thanks anyway. Been looking for a workaround besides applying forward velocity…

I also have this teleportation problem i just posted:

Fits right into what you just said about stuff not working the way you think it should