Thumb Mouse Button, Thumb Mouse Button2: Broken

Under Project Settings > Engine - Input, I’m able to create Action Mappings or Axis Mappings that use Left Mouse Button, Right Mouse Button, Middle Mouse Button. However, when I try to use Thumb Mouse Button, Thumb Mouse Button2, it does not work. I have a normal mouse with forward and back buttons.

Hi, I just checked the thumb mouse button input should work fine. Make sure you have the correct input mode and that the input is not consumed.

I just tried (for the first time!) and it worked as it should. Does you thumb button/s work in other application/games? Maybe you just don’t have them setup properly.

I have a Logitech Corded Mouse M500 on Windows 10. The Forward Back buttons work as expected on the Windows desktop.

I don’t think it’s the input mode because all other mouse buttons work in UE4 - mouse left, mouse right, mouse middle, mouse scroll up, mouse scroll down.

I just tried a Logitech M705, and it has the same problem. But then I tried my Razer mouse, and… it works! So I’m not sure what to make of this. Maybe it’s some quirk related to UE4 support for Logitech mice.

When I did a google search, I found League of Legends message board posts complaining about what sounds like the same problem…

I know this isn’t a solution really, but do you happen to have another mouse you could plug in? Best case scenario - it works, then you’ll know it’s something to do with your mouse not the scripting or editor settings
Worse case scenario - you can use the other mouse until you find out what the real problem is.

I have done some reading and it seems a lot of people have problem with their Logitech hardware.
I’m assuming you have up to date drivers for it, question is do you have a separate software for your mouse (like a control panel). If you do, save you current settings and try resetting to defaults if you can, maybe play around with key bindings. It’s been years since I’ve used a Logitech mouse and I don’t have one right now just to test things.

Nothing else comes to my mind right now. Worse case scenario you will have to use your Razor for now, at least until the cause for this can be found.

Thank you for the ideas. I was able to fix it.

I went into Device Manager, and did Uninstall device → check remove driver. For all of the mice except Razer Mamba. Then my Logitech mouse does not work at all, so I unplugged it then plugged it back in, and now it works in UE4 as expected. So I suppose it’s a Logitech driver bug.
Though it’s a strange bug to work on the desktop but not in UE4.

Great news. Happy you were able to get it working!

Just to clarify in case someone else runs into this issue and still wants to use Logitech Software:

G4 (thumb button) is now assigned to Use Generic in Logitech Software and this will work fine in UE4. If you assign it to anything custom, the software catches that and the generic button 4 press is no longer passed to the engine - UE4 simply does not receive the appropriate call.

You can assign the thumb button as the K letter for example, and the software will pass it as K and UE4 can catch it as K. The generic mouse 4 is not sent in this instance, though - it was replaced.

Since Logitech Software detects the running exe, switching profiles can be automated (and works fine most of the time as it’s faaaar from perfect anyway)

Logitech M500 uses SetPoint

And your point is? This is Set Point, what it started as, at least - same thing, the old software has the same (less refined) functionality. Logitech has unified its software for most of their devices.

Perhaps some older devices still use older version, not keeping track of all mice on the market :slight_smile: This should still be applicable, no?

Weird so now it works when game input mode is game only, but not UI (UMG)