Thrustmaster T300 driving wheel setup

Hello, I have a problem setting up a Thrustmaster T300 Driving Wheel using the Raw Input Plugin.
The Device is detected by my computer but in Unreal I cannot get input from the steering wheel rotation.
Pedals work well although some buttons on the wheel are not detected either.
I had to T500 RS wheel before which I used in 4.22 and never had problems with it.
Can anybody help me through with the setup?
Thanks in advance for any help.

The Thrustmaster inputs are a mess. When I inquired with the company about their wheel’s input setup, customer service threw it back to Epic. Total fail.

Luckily, I was able to get away with using other wheels (the HORI wheel for PS4/PC is a good alternative). I created a demo – was not for market.

If I had to do it again, I would attach a print statement to every possible input just to detect what the Thurstmaster signals are.Painful as this might be.

I would definitely include a Settings Screen option for players to customize the inputs. Different wheels have different inputs.

Hi Doctor_Kannon, Thank you very much for your help.
The wheel is working now!
I reinstalled the drivers, plugged the device in another usb port and it just worked as expected.
I didn`t change anything in Unreal, so it looks like there was some kind of problem with the device installation itself.
Thank you very much again for your advice!

Good to know you were able to get it working.

Some questions for you:

  1. Where are these USB ports that one worked, and the other didn’t?
  2. Does the first USB port work now that you updated the drivers?

Thanks!

Hi Doctor_Kannon, Sorry for the late reply.
Here are the answers to your Questions:

  1. They were just the normal USB ports in the back of the computer.

When I first installed the device I made the mistake that I had plugged the device before installing the drivers, instead of doing it during the drivers installation process. I’m not sure if this was the reason but I noticed that the first time I made the install, the device appeared as a “FFB Racing Wheel” in the Thustmaster`s device Control Panel. At this time only the pedals and some buttons were detected as inputs in UE4.

After I reinstalled the drivers (using a different USB port) it appeared as a “Thrustmaster T300RS Racing Wheel” in the device Control Panel. It then worked as expected in UE4 without changing any settings inside my Project or the UE4 Editor.

  1. Yes, it works well as expected in any USB port of my pc.

Thanks again for your help!

Hello DanielHG:
i have an issue about t300, i cant activate steer pull back force, can you?

forget it ,i fix it with thrustmaster’s control panel,change Auto-centering settings with “control by steer”