Download

Those dreadful drag-out pins...

Yes, the area of pins to do drag-outs. Slight but the annoyance builds up
it’s different from this], as that one goes more for the inputs (which are not that problematic for me)

So why do the pins highlight when they shouldn’t?
In the material editor:
dragout1.gif

In blueprints:
dragout2.gif

Please can we have a fix for this?

I concur, single most infuriating thing.

One of the main reasons why i do not like bp, i hate this soooooo much.

As well as not having the ability to lock/unlock a node to a position in the graph.

Or a group/ungroup a set of nodes to move or not move together and keep relative positions without a comment.

Also Comment nodes should have the ability to type comments as a text block. for example you could hit a bool var in the comments details, so that it would fill its body with a text space so you could have larger more readable and digestible comments

Wow, didn’t know other people hated this as well.

When something like this happens, I slowly start to rage, until it happens too often and then I just go FAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAACK.

I just have to call it a day then.

Anyway, only being allowed to drag a blueprint by dragging the title of it would be the easiest fix, but that would probably also cause annoyances with dragging blueprints then.

The best solution would probably be to increase the hitbox (or whatever you want to call it), just make it nice and big so miss clicking or dragging is basically impossible.

++ this makes me sad too :frowning:

Hey guys,

Thank you for this feedback. I will see about entering an feature request to improve the accuracy of selecting pins within the editor graphs, as this seems to be affecting a good amount of users. I have also noticed this on my machine at home or while sometimes working and Mac and their is heavy processing on the CPU.

Cheers,

Andrew Hurley

awesome, thanks for the response
I hope the pin pixel hunting will be gone soon :slight_smile:

Hate that too :confused: Also bigger snap radius will be great.

I belive bug report would be better then feature request, this must be updated asap, not just “maybe later” :slight_smile:

Drives me crazy as well. Thanks for highlighting this problem!

I used to get really annoyed by this, but then I got used to selecting next to the pin and dragging onto it.

it seems that it doesn’t detect a drag until after a certain distance of dragging, probably to distinguish it from a click.

I have no idea why it doesn’t store the original position of the click, rather than the position when the drag was detected…

quick and friendly bump. I still struggle with this, and I see this happen to the Epic guys on Twitch :stuck_out_tongue:

Doing the February Game Jam in blueprints and this continues to be infuriating :smiley:
Please fix!

Here is how I feel working with blueprints and this issue:

:stuck_out_tongue:

My studio is moving from UE3 to UE4. And once again, I faced this pin issue many times in the new project. As I don’t forsee myself (as well as my team) dealing with this in the future, risking my mental health, I briefly investigated it ^^.

And I pinned this pin issue !
Here is a very simple fix:
Search “SGraphPin::OnPinMouseDown” and you can see there that the mouse down is only proceed if it’s more on the right side (threshold at 50%) of the widget, only for output pins (not the input ones).
Simply replace the whole content of the function with “return OnPinMouseDown(SenderGeometry, MouseEvent);”

This fixes the selection so when the pin is hovered (the pin is highlighted) the selection works properly. It applies everywhere this pin is used so it works in both the Blueprint Editor and the Material Editor :slight_smile:
As far I’ve tried, I’ve seen no side effects yet. Also, the reroute node is special (as it’s only a floating pin) but it’s still working properly.

To be fair, I have no explanation for this 50% check and I am curious about what you, Epic, can explain about it :slight_smile:
I tried to check on UE4 Perforce to “blame” on this file but I failed because I didn’t found such feature in P4V (and I didn’t found a convenient way yet to “annotate” in P4V).

Anyway, I’ve made a pull request (4.11 preview 8) of a complete and proper fix. This also fixes the mouse over cursor. You can check it here:
https://github.com/EpicGames/UnrealEngine/pull/2202

Here is a gif for Chosker :stuck_out_tongue:
UnrealPin1.gif
And another one where we can see that it applies to the whole name in the pin too:
UnrealPin2.gif
(at first I made a change which only allow the click on the “icon/image” the pin contains but in my feeling that’s much better when I made it work on the whole pin + name)

At least, if Epic accept the pull request, it will make much less Epic devs on the stream facing the same issue in front of all the viewers (and kept on Youtube for posterity) ^^.

Thank you for taking the time to fix this. Its something I have hit without even knowing it was a bug. I just assumed I mis-clicked. Super annoying.

Thank you very much Lucyberad… implemented!

Awesome! Will try to merge it into myself today.