A thirdparty that I use in my plugin defines C++ function “check” under its’ own namespace. However, the project fails to compile because of UE’s “check” macro defined in AssertionMacros.h.
Regardless of the DO_CHECK value, it always evaluates to something, so that build fails.
I believe, such macro shouldn’t have generic names like “check” but rather be prefixed. like ue4_check or something. However, it is what it is.
How this issue can be resolved?