Third Person Tut FBX Animation Issue (MODO / Maya / UE4 FBX Animation Discrepancies?)

Trying to figure something out and I’m hoping it’s just my noobish greenness and not a deeper issue. I’m learning Unreal and following along the ‘Introduction to Third Person Blueprint game’ tutorial and I’ve hit a snag that I can’t seem to fix with the tools I have available. The supplied FBX set from that tutorial seems to now import into Persona with missing end frames in the Walk, Run, Jump_Loop and Jump_Start animations.

Bringing the FBXs into MODO seems to yield the same issue as in Persona. The Walk animation as an example: in both MODO and Persona, everything but that last 31st frame is there, killing the loop.

Not entirely sure that this thread is discussing the same issue, but in case it is, that solution doesn’t help me unfortunately – no Maya.

What I’ve tried:
Using ‘Add Looping Interpolation’: Doesn’t quite work, resulting animation still has an unacceptable hitch.
Opening the animation in MODO: No dice. Animation imports similarly as it does in Persona.

I see you wrote the animation “now” seems to be missing the “31 frame.” While I agree it does appear to miss a 31st transitional frame, I’ve have a Test bed using this asset I created almost a year ago and it has always been only thirty frames and somewhat “jerky.” Did it used to be correct and is not now?

They look to be the correct length in the tutorial videos and the file hasn’t been updated on the wiki from what’s shown: A new, community-hosted Unreal Engine Wiki - Announcements and Releases - Unreal Engine Forums.

I noticed the same thing after bringing the FBX into Maya. In following the tutorials, there doesn’t appear to be a skip in the video, but at the end of the transitions in the imported FBX it skips. Not sure if the file got screwed up or something but I noticed a few other things too. I don’t know what the timebase was for these, whether it was intended to be looked at with 24fps or 30fps in mind(I typically work in 24fps for film work), but the time slider shows the keys at odd frame counts, like frame 2.30 or something. Instead of getting baked keys at individual whole frames. I didn’t see any odd messages or settings when importing to adjust this either. But the transition end frames are still missing.

ps. Despite the hiccups here and there I am absolutely astonished by the wonderful content, tools, and attitude coming from Epic Games as of late. Making UE4 free and fostering the wonderful community that is growing is truly remarkable to be a part of. Making the prospect of actually developing and learning how to make a game has been on my “to do” list for some time, and now thanks to you guys I’m finally able to take that in my own hands and learn. Sometimes it is not just knowing what you want to do, it is knowing the right questions to ask so you can get there.