Third Person Template Launch to Android Crashes editor

Hello, I’m new to Unreal and I wanted to try it’s capabilities for mobile.

I followed the android quick start quide and tried to launch the template straight on to my Note 4.

  • I installed UE 4.13
  • I installed VisualStudio Community 2015
  • I installed CodeWorks 1R4u2 (full instead of standard install)
  • Made sure my device is listed in adb devices
  • Made sure the SDK location is set up in project settings
  • I created a scalable 2D/3D project for mobile without starter content

I assume picking the texture format happens in the Project Launcher. This wasnt described oin the guide ( Whenever I launch on my android device, with or without the texture quality set to ETC1 in the Project Launcher, the editor starts the launch but crashes after a few seconds.

Using the Project Launcher, I can get the project on my phone with at least ETC1 textures and API 19, regardless of multiple errors. However, on the phone, it only shows up as the splash screen and nothing more.

These are the crash logs I got

link text

link text

and here is the XML in txt form:

link text

Am I doing something wrong?

Hi Roksi,

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?
  • What steps can I take to recreate this on my end?
  • What are the specs on your phone?
  • What size textures are you using?
  • Is the project crashing or are you only seeing a black screen?
  • Is it a packaged project or are you launching on the device?
  • In your Project Settings>Maps&Modes, do you have an initial map set for the packaged game?

In the future, please make sure to list these types of questions in the correct location. If you are experiencing a bug, the bug reports section will be more useful. If packaging related, send the question to the packaging and deployment section.

When I open Unreal I go to New Project > Blueprint > Third Person > Mobile > Scalable > No starter content and name the project. Then I go Launch, pick my android device from the top of the list and wait.

I just tested it again, and the first time I tried I got an unknown error that I logged up into a txt file. Then I opened the old project and tried to launch and it crashed. I started Unreal up again and went to the new project and tried, and it crashed too.

What are the specs on your phone? My phone is a Samsung Note 4, SM_N910F, running android 6.0.1

What size textures are you using? I haven’t touched any texture settings.

Is the project crashing or are you only seeing a black screen? The editor just closes.

Is it a packaged project or are you launching on the device? I am launching.

In your Project Settings>Maps&Modes, do you have an initial map set for the packaged game? Yes.

I posted here because I don’t really know about the nature of the problem. I only just installed to compare Unreal to Unity and see what Unreal can do on mobile.

I reinstalled the SDK twice, once with 1r5 and once again with 1r4 with full install.

Try reinstalling your SDK, as seen here:

I’ve checked to ensure the Note 4 is supported and it is, so compatibility is most likely not the cause of the error. If re-installing the SDK does not work, please let me know and we will continue trying to find the cause of the error you are experiencing.

I haven’t been able to reproduce this on my end with the steps provided. Can you provide a sample project this is occurring with? Have you checked to ensure your drivers are all up to date as well?

There is no real sample project, its the same exact out of the box project that comes with unreal 4.13. I can recreate this consistently with the steps provided. My graphics drivers are up to date, just updated, same with the USB drivers.

I tried reinstalling UE but I’m still getting the crash when launching. How could I gather more data to figure this out?

There are a few more options to try on the link above, starting here:

I reinstalled everything again and still the problem persists. I was able to locate a crash log:

link text

I also went through the troubleshooting guide with no luck.

In order to better assist you, I’m going to need for you to provide me the logs from your mobile device.

  • Attach your phone to the computer
  • Go here: C:\NVPACK\android-sdk-windows\tools
  • Open up Monitor.bat
  • Launch the program and save the logs

If you cannot get Monitor.bat to open, please go to:

  • C:\NVPACK\android-sdk-windows\tools\lib\monitor-x86
  • Open up Monitor.exe
  • Follow the instructions above

Make sure that you highlight all of the logs, because they do not save unless they’re highlighted.

Thank you!

Neither work, both crash with “An error has occurred. See the log file” :frowning:

link text
link text

Do you have another phone you can try to launch on?

Okay, the monitor.bat thing is working now. I can’t find any mention of unreal in the logs when I crash the project.

Log from starting monitor to starting ue to crashing, two testruns:
link text
link text

Heres a log from trying to launch through project launcher - only gives me the splash screen on the phone:

link text

Not currently, no

Can you try launching the project to Windows and see if the same crash occurs or if this is specific to the device you are launching to?

it seems to work on windows just fine.

While I was not able to reproduce this on my end, it may be related to another bug we recently fixed. I’ve entered a bug report, which can be viewed here. You can track the report’s status as the issue is reviewed by our development staff.

Thank you. I’ll try to find another android device to launch to meanwhile