Download

Third person character blueprint broken, camera snaps inside

Hi

I setup a scene with the basic third person character blueprint , it was fine for a while but all of a sudden the camera was snapping to the inside of the third person character. I tried moving the camera away from the character but the movement of the character was lost. I`ve been trying different things like bringing in a new third person blueprint and the camera is still set inside the character, and all that seems to have done is when I play the game I get a view from a camera set at 0,0,0 in the world and not the one behind the character.

Any ideas? I tried this technique of migrating a third person setup into my scene but It just crashes unreal when i try and adjust the world settings/gamemode.
https://forums.unrealengine.com/showthread.php?61472-Help-with-making-third-person

Thanks

Could you post a screenshot of your character bp component tab? :slight_smile: + check your project settings-input if there is still everything correct
Also make sure to post your log file which gets generated after the crash -> documents-unrealprojects-yourproject-saved-logs

Sure , this ok?

Thanks.

69869b2cd975df64c9b6b42634e4820aed23dd42.jpeg
inputs1.JPGinputs1.JPG

Hi,

Do you have another actor attached to the third person character?
I had a similar problem once when I attached a riffle actor to one of the spine bones socket.
The solution for me was to set the riffle collision preset to ‘OverlapOnlyPawn’.

Any progress on this? I just switched to 4.13 and got after trying to use matinee same problem as you described… that’s ridiculous…

:smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley:

Well, RIDICULOUS is what I did :smiley:

Trying to let my character moving within matinee, I have inserted some code to level blue print, because I was sure I have to… well it didn’t work, I was distracted and then I have tried something else… after a while I have re-discovered “cinematic mode” settings… well and at this moment I have completly forgotten about my level BP, which I left partly broken… :smiley: :smiley: :smiley:

Well, guess what was inside?

Set View Target with blend

and no view target specified :o

problem solved, maybe it will help somebody else later :slight_smile:

just a little detail here from 3rd to 1st person …
If your animations are not setup for 1st person, they will most likely be very jittery and lose that “smooth” transition feel while in 3rd person. I have tested this with several 3rd person animation sets, to include, MOCAP animations. Just keep in mind, if they are not made for 1st person, they will have visual issues (will … might … they might …).

I’m having this exact same issue. In one of my levels there is a matinee setting giving me the exact same problem you had exact I can’t figure out how to fix it.

Well, I too am having the same problem, but it’s cause is unknown to me. Start a 3rd person template, and then import a large object. Object requires scaling, so I scale away. Neither the X or Y axis scaling affects the camera, but the moment I scale on the Z axis, the 3rd person camera snaps to the center of the actor, and then it becomes impossible to play. Any thoughts?

My thoughts are that I create all objects at the same scale and avoid all these problems.

It has served me well.

I had the same issue recently and I was able to solve it. Basically I had adjusted the relative x location of the camera boom. This resulted in it starting in a position outside of the character collision capsule. When close to a wall the start position of the camera boom would collide with the wall and the camera would snap inside of the player. So to fix it I just had to ensure the relative position of the camera boom was always inside the collision capsule.

To check if this is the cause play inside the editor, then eject from the player character, then click on the player character and you should see the camera boom as a red line. If the camera boom starts outside of the collision capsule this could be your problem.

Hi everyone - a fix below if anyone is still looking for this.

I had this issue with the camera snapping when getting too close to objects, pawns.
What I did to fix it was simply disabling the “Do Collision Test” option under Camera Collision for the CameraBoom.

Running UE4 v4.23.