Download

Thieves Island Needs YOU==== potentially

So this is the island so far I’ve released…its got a good amount of caves and the start of a pretty cool underground system that runs under the island connecting a lot of the tunnels and caves together.

I need help with lighting though and some other things like weather and sound (i can’t get sounds to work) if someone was willing to donate some time to help me fix these issues…id appreciate it.

I should warn you now…I was voted “Worst Screenshot Taker” at both SEGA and 2k Games when I worked there LOL

I’ll add some cooler shots later today

To get sounds to work you need to put in a trigger box and then attach the sound to it so when you move into the box it triggers the sound.

This might help

:slight_smile:

It works to a point…I still need to check it “live” but in preview it works …ok.
this video may be out of date. some things he did…you can’t do anymore so I had to figure it out without his help.

but it got me to the next stage…now lighting. I REALLY need to get some help with lighting.

Glad it helped :slight_smile:

What’s the matter with your lighting ?

It stinks on ice. I feel its too dark in some areas and too bright in others. I want it to look …well real…and beautiful right now (look at my screens) it looks a bit off to me. Especially in game.

I also can’t get some textures to show up no matter what i do. even if I push all the assets into the mod maps folder (properly) they still don’t show up.

i’m at my wits end with that last one…I have a cave with blue mushrooms in it…blue lighting to accent them, add a bit more glow. You go in it in the game and there is no texture so it looks like ****.
I’ve replaced them, 5x

Ok

Lighting is simple

Just check that it is set up exactly like the island, best way to do that is to open the island map and your map at the same time and then check each one’s details. Or screen shot all of the detail settings what ever your PC can handle.

When you have checked that all the settings are the same and I mean if its says 0.02 then set it to that.

Once its all set the same

  1. Click build at the top next to play in the Editor and click on update reflection captures.
  2. bp_sky_sphere Under details click Refresh material and then untick it
  3. Skylight Check the Bake and stream and then turn it off.

For caves have you put a block out around the whole cave so that it doesn’t get the lighting from outside (if your lighting is broken which looks like it is) you will have problems in there.

:slight_smile:

Yeah I am having mad issues with lighting in the caves…its making me crazy. they are so dark even with many point lights in them…black as night. its lame.

ok so I should be looking just at the directional light on the main map yeah?