There was an issue logging in. Please try again in a few minutes

Is anybody having this same problem? It happens whenever I try to reach the academy, and it’s been going since I tried to access it this morning. I haven’t been accessing the academy since before Christmas.

It just redirects me to https://login-academy.unrealengine.com/Register/PleaseTryAgain

I have tried with Chrome and Firefox, same result. I emailed UOLSupport@epicgames.com

Many thanks in advance

Having the same issue. Did you get it resolved?

I have the same problem too and can’t watch any courses.

@Dr.R.Krauss Are you using an Epic Games login with email address or are you using FB, Google or another option to login?

I’m using my Epic Games account. I’ve tried also with a google one but still getting the same result.

Thanks, that was my next step. I sent an email to support as well, so hopefully they look into it next week. It looks like it’s an ongoing issue, I’m seeing posts from a ~6 - 12 months ago with people saying the issue just stopped.

I having the same problem some could resolve the issue??

Can Someone help me ? please?

I wrote to support but they say that can’t helpme :frowning: