"There is no disk in the drive" error on audio asset rightclick

Right clicking on some assets in the CB returns a windows error message box with “There is no disk in the drive. Please insert a disk into drive D:.”. I could only replicate this error with my Universal Sound FX sound files, not with cues, just the sound files. Other sound files (checked with Infinity Blade sounds) don’t give this error. This error persists across different projects and after re-importing.

Looking through the settings at the source directory, it looks like it is pointing at the D drive instead of C (I don’t have a D drive on this machine). So it seems that is the problem?

I only started having this problem today. I had an update for Windows 10 today, that’s the only thing that’s changed if that affects things. This is on v4.9.2.

maybe you imported the files directly from a UBS stick, which was temporarily assigned to D:\ ?

couldn’t you just re-import those assets from your C:\ drive? (Just trying to help, I agree with you that this shouldn’t happen at all)

No bother, I appreciate the help.

But these were purchased assets from the Marketplace, no USB sticks involved. The directory given for importing the assets (both with and without errors) does not exist on the C drive, or it is some kind of hidden folder. I’m a novice with the directories of the various referenced parts of the engine so I’m not going to poke around with things too much.

Hey ag858,

I would honestly re-download these assets from the marketplace and be sure to make note of the directory. Then navigate to the directory and be sure those files are there. Try importing again to see what happens after doing this.

Let me know what you discover to be the outcome.


But the marketplace download doesn’t indicate the directory of the local content (as far as I can see) and source import folder as indicated on the asset doesn’t exist or is a relative directory?
I’ve tried copying the folder from the default marketplace local content directory (C:\Program Files\Epic Games\Launcher\VaultCache[folder]…) but can’t seem to get the files into the project. I’ve tried drag and dropping the folder but that gives a whole load of import errors.

I’ve also tried pasting the local content directly in to the content folder in windows explorer but it won’t show in the Content Browser.
I’ll keep trying and post what I find here.

Okay, I’ve found that despite the error message on right clicking, I can still make sound cues/ambient sound actors and audition and pick sounds from inside the editors in the normal way, which is all I wanted to do. Sorry, I should have verified this first before going on the error hunt. You can mark this case as resolved if you like.