Theoretical Performance

Thanks for the post Chrono I will analyze your post / the Couch Knights scene a bit more later tonight when I’am not at my day job :slight_smile:

Thanks for the details!

I’ve been working at getting some of the heavier marketplace scenes working on the rift. I’ve even gotten the huge landscape demo to run at 75fps on my gtx780 by lowering settings down and following a few basic rules.

  1. Turn off frame smoothing (under project settings>rendering)
  2. Switch AA to FXAA (PostProcessVolume>misc - if you need to, click the eye icon and display all advanced options)
  3. Turn off all PostProcess effects that aren’t absolutely needed. Override and zero them all out.
  4. Lower screen percentage. You can do this in-game with the console command “hmd sp 100” where 100 can be lowered to 30 if needed. I think for the landscape demo, I went down as far as 80. It looked so-so, but 75fps!)
  5. This one is bad form if shipping a game, since it’s hard-coding graphics settings. But for developing and just getting things to run faster check out this link. It shows an easy way to apply scalability settings in your standalone test. (normally, scalability settings will not carry over to your standalone game, and are only applied to your viewport). You’ll have to experiment with the right settings for each one in your game, but it’s very powerful. Also, for the rift, don’t use “resolutionQuality”, instead use the “hmd sp” command. 0=low 1=med 2=high 3=epic

if you want check my landscape version.
https://drive.google.com/file/d/0BwxDpHXNiiBWTGRhMWtnWnFQMGM/edit?usp=sharing

i got 75fps with a r9-290 in near all map, except when i spawning with the lake in front.

sp = 100

compiled with 4.4.0 you need pause the oculus service.

Hi there,

just wanna ask how are things going with this. In my project, GPU load in my VR project is around 55% which is just horrible. I was hoping for an implementation of late-latching, I could swear this was also announced in one of the former Twitch Broadcasts about the state of the VR integration.

So, what’s the state? I would really, really appreciate some more throughput in my project.

Many thanks,
spyro

I really dont understand the performance in RIFT with UE - I have UE4.8 but see similar performance in UE 4.7/4.6:

Regardless of the performance settings I choose I seem to get capped at <40 FPS. I have a Dual SLI Nvidia 980 with >4gz intel and Raid 0 SSD drives so its not for lack of machine capability (I know SLI isnt supported but…). Without rift and everything set to EPIC i get well over 100FPS even with the editor running - when I run the VR blueprint i get 37 FPS - even if i set all the quality settings to 4 and AA to 3 or 4 (or 0). I have tried hmd sp ranges from 70-180 and I get consistently 37 FPS throughout with or without the editor running.

I have tried all the options I can find including copying the coach knights global PP settings but I always get stuck around 37 FPS.

What have I missed?

EDIT1:

Typical that just after posting I may have found an answer to some of my performance issues: If I set LOD to Low for Reflection capture boxes then I get a pretty descent 60-75FPS with the editor open (clearly better when running stand alone).

@geekyhawkes - make sure the frame smoothing isn’t on - I had a problem where if frame smoothing was on, it would bump me down to 40FPS even if it were really running at >75.

@n00854180t: Yes, I’m trying to find out what exactly ‘smooth frame rates does’ since about 10 months or so, but until now it’s not known (and epic doesn’t answer to the question): https://answers.unrealengine.com/questions/90743/what-exactly-does-smooth-frame-rate-do.html

Thanks - I had a play with smoothing - It was a killer to start with but I have had it off for some time. I just feel that overall VR performance is a bit low but Im hoping it will improve as each version of UE/Oculus SDK comes out.