Download

The two forgotten tips that can double FPS in the editor

I recently went through almost every rendering setting and packaged many builds. In my initial experiment, with just a black screen empty level, the FPS went from 60 to 340.
Now, with a default map open, lights and all, it went from around 30 to a bit over 60. I haven’t packaged this new project, but it should still give a boost.

Forget about Lumen, Shadow Maps and scalability settings, all though these help a bit. I’m on a MacBook Pro 2019, so Lumen Virtual Shadow Maps and scalability are probably bottlenecked, explaining why none of these affect the frame rate at all.

What you really want to look into, is to turn everything off in the default settings under Render Settings and enable forward shading. Just “Bloom” in a nearly empty map takes like 2ms on my Mac.

Switching to forward shading will compile all the shaders next time you open the project. The same goes for quite a few settings.

And now the extra most overlooked tip of all: You need to optimize your computer. Google Chrome can easily eat up a Gigabyte of RAM with few windows open. Discord and Reddit both use between 0.5 and 1GB. Look into anything that happens during the startup of your computer, what runs in the background. For Mac users, the enemy is iCloud, for PC users, probably tons of things you didn’t even know existed. I wiped my Mac clean, after deleting everything I could find, including pictures, docs and other personal stuff. All the cached data since 2019, belonging to programs I had already removed, was somewhere between 150-200GB…

When you use Unreal, close down everything else, including the EPIC launcher, unless you need the internet while you work, then only open what you need, then close it down to not have half of your RAM eaten up by twenty browser tabs.

1 Like

Hey I just wanted to thank you for sharing this.

I hadn’t thought about forward rendering, so I went and investigated a little more about it. It looks like the features that it does not support weren’t anything my project makes use of. So I enabled it and restarted the editor…

…and my project is now running about 30fps faster. Pretty darn amazing! On max graphics settings on a 1060 gpu I now have 60-90fps most of the time. Mind blowing. And I haven’t lost anything in the process. Just ticked a checkbox.

1 Like

That’s very cool. I have been wondering what would happen on more capable GPUs than my “Intel Iris Plus Graphics 655 1536 MB”