Download

The skin of leg is out of shape and looks ugly in unreal while well in DAZ

Hi everyone. I export genesis 8 basic female using DZA to Unreal.

When I adjust legs in Unreal, I found the skin is out of shape and looks ugly in unreal. But everything is well in DAZ.

45 degree, slight deform in Unreal, but well in DAZ:

15 degree, obviously deform in Unreal, but still well in DAZ:

I don’t know the reason. Any help would be appreciated.

I think it is because Daz3d and unreal deal with bones in different ways, you can check this out.

Adding some bend control morphs may be helpful, but I haven’t tried that myself.

I think you are missing the corrective blendshape.
Also possibly the LOD level is kicking in, if there are any.
Otherwise there’s the possibility you just need to increase the skin cache fidelity.
You have to recompile the engine for that and it may be something covered in the article already shared too - it really should since its mostly an issue when working with their product and nothing else…

A Genesis framework model, 1 2 3 or 8, makes use of what’s called a JCM, or Joint Controlled Morph that corrects the joint using a morph target based on the angle of the effected joint. Other apps makes use of this technique as well like the morph angle deformer in 3ds Max.

If you wish , if using the bridge, you can export the JCM shapes and use the anim BP, as part of the DazToUnreal to preload the shapes

All the answers are very important to me. :smiley:
Are there any examples for this problem?I dont’t know how to start…

I found JCM in this article: [Daz To Unreal – Applying JCMs (Joint Control Morphs) – David Vodhanel]
Here is the result, but same in 15 degree:

BTW. I found another problem, the axis is different in UE4:

So is there any example for dual quaternion support?

The axis may look different, but its probably not.

Dual quaternion is just better rotations, not necessarily better mesh skin precision.

What’s happening in your cases, aside from having no JCM, seems to be a precision driven problem…

Usually, it’s explained solved on topics that complain about morph target shadowing / display issues.

The reason behind the lack of precision is simple.
This is a game engine, not a 3d app.
You can change the code and build from source to increase that precision - but it isn’t needed for most if not all videogame, so it’s not the “default”.

Access SkeletalMeshImport.cpp
Change the threshold value to your liking, compile, and import the mesh.

If the issue was the weight paint precision, it will look much better.
If it wasn’t, then it’s probably a missing JCM…

Thank you :smiley:
I will try this.
It’s a simple way to verify this, just debug in applications like RenderDoc, bu I don’t know how to dubug frame in DAZ.

Keep in mind that the bridge is new and will take time to tweak. There has already been a noticeable difference with the 4.26 bridge.

In the mean time be sure to check out the “DazToUnreal Content” folder as well as Daz settings under Project and Editor preferences

By using Adding Dual Quaternion support @fengkan and JCM @FrankieV, the result is well in UE4.
Thank you verty much.

leg1

1 Like

Greetings
How do you do this on Mac?