Download

The skeleton for my models animations is importing incorrectly.

Whenever I import my model with it’s animations, nothing will work properly when they play. I looked at everything I imported, and the skeleton is “Shuffled” for lack of a better term. Each bone in the skeleton is shuffled back on position to the parent’s position all the way down into a non-existant bone at the center. (Meaning I never created the bone in Blender, but it now has one originating from a center-point)

I have absolutely no idea what is causing it, and I’ve tried every variation of import settings, export setting, engine settings, modeling program settings, engine releases, modeling program releases, naming conventions for the armature, etc. I’ve spent nearly 2 weeks trying and I just can’t do it, I need some assistance.

I have a tutorial for you:

This guy has been making a game for like a year and a half now and he uses blender for modelling.
At one part he talks about using blender models with Unreal animations so maybe this will help you. And also Welcome to the community!

Thank you for the welcome.

I have seen his video in my efforts, and everything that was displayed in the video I tried as well to no avail.

Hmm, sorry mate cant help you

2 weeks, that indeed a lot.
well how about to try a simple model and 3 bones and then test it in ue4, it could be u missing something or found some clue there.
But i thk it come down on how u made the bones workout in blender, try to simplify it. Like for example bind only the left hand bone to the mesh and see how it work step by step.

I’ve tried it with a simple straight line mesh, then added bones and parented it with automatic weights. It still pulls the bones back slot, and has nothing were the final bone should be and the first bone shrunken back to a singular non-dimensional point. I might just try a different modeling program to see if that was the issue.

you can upload your blender model here for us to see if we can find the issue.

Wait, I know. Have you Parented your bones? because in one of the parent settings I think it sends the bones down to origin or snaps them all to one bone. so maybe you selected the wrong parent option.

Here’s a picture of what I have going, the FBX is too large and wasn’t too sure about how everyone feels about MediaFire links.

Here’s how it looks when it’s imported into UE. Notice the bone name and position in contrast to the blender file. Sadly I couldn’t select then entirety of the skeleton to get a better view.

ye usually the bones representation in ue4 is never exactly the same like in blender so i wouldnt worry about it.
you should try on ue4, could be ue5 has some issues with animation.
did u get any message error when importing ?

Can I just say that is a slapping model there!

I didn’t get a message when importing other than successful import, I’ve also tried it on every iteration of engine installed as well as iteration of blender back to 2.7. I’ve even made other really simple models to try and fix it, like a snake with only 5 bones and it did the same thing. Sorry for taking so long to get back.

@KirBZ Thanks.