Download

The seam is obvious when I try to pixelate texture

I pixelate the default texture use in this simple way.


But there are obvious seams between the blocks. I don’t know why. If it’s a precision problem because of floor, I think the seams should have the same color as its neighbors.

It is more obvious on the simple Grid texture.

This issue is impossible to avoid i think. The best solution to it just to use an already pixelated texture, using nearest filtering.

Yes, I think you are right. I gave up after many attempts.

Were all pins the same?
Second texture render seems like it has normals or something altering it anyway.

In terms of final result, I did something similar and had similar issues. Changing the antialiasing post process settings helped - enough to be able to use it.

You are pixelating different mips, which causes the seams to appear. In the texture sample node, set “Mip Value Mode” to “MipLevel (absolute, 0 is full resolution)”. This will set the texture sample to always use mip 0, or it can be changed through the “level” pin that gets added.

Yes, all pins were same. Thanks for your answer. I will try it next time.

oh my GOD!!! You’re right!!! The result turns out to be wonderful! I truly get what I want! Thank you so much!!

1 Like