The project crashes on Packaging, works fine in Editor!

My project refuses to be packaged!
I’ve tried pretty much everything to get my project working, but its to no avail. It runs fine when I press play in the editor, but after I package and then try to run, it crashes right away!

This is the log I am getting [link text][1]

I can’t seem to figure out what is wrong with it! it says array is the problem but then when i use the debugger, it shows that the static mesh of an actor is the problem.

If I just flat out remove the static meshes, i get this error [link text][2], which says that “Objects have the same fully qualified name but different paths”. The error message then precedes to show me the two paths “New Object: B_Shop_C /Game/Structures/B_Shop.Default__B_Shop_C Existing Object: B_Shop_C /Game/Structures/B_Shop.Default__B_Shop_C”

The paths look completely same!

I have a sneaking suspicion that it has something to do with the warnings LogUObjectHash:Warning: Ambiguous search, could be DynamicClass /Game/Structures/Shop.Shop_C or DynamicClass /Game/Structures/Shop.Shop_C but then again… the paths look exactly the same! and there is only 1 object there!

96336-rgbshooter.log (15.6 KB)
[2]: 96337-rgbshooter.log (19.9 KB)

My Project Download Link:

If i delete the “potionshop.uasset” (an old actor which i no longer use, and cant see in my content browser) in my project folder called “structures”, and then turn off the nativize blueprint assets, it works… But, I would like to use nativize blueprint assets could this be a bug in nativize blueprint assets?

Hey Espii77,

[2016.06.28-01.38.01:088][ 0]LogWindows:Error: === Critical error: ===
Assertion failed: (Index >= 0) & (Index < ArrayNum) [File:C:\Program Files (x86)\Epic Games\4.12\Engine\Source\Runtime\Core\Public\Containers\Array.h] [Line: 804]
Array index out of bounds: 0 from an array of size 0

This is the error that’s seen within your project logs provided.

Have you tried deleting your Intermediate and Saved folders from your project? I’d also try the following, as it’s a similar issue I’ve seen before from 4.7.

Open SwarmAgent.exe (Unreal Engine > [Engine Version] > Engine > Binaries > DotNET )

When you double click this it will place an icon in your task manager. Open that. Go to the CACHE drop down in the menu bar. Click CLEAN and then VALIDATE.

Also, Go to this folder location (may be a hidden folder on your computer so you’ll need rectify that before you can see it) C: > Users > [ Computer Name ] > AppData > Local > UnrealEngine >

Delete everything in this folder. Make sure to have the editor closed otherwise some errors will be thrown that you cannot delete files.

Looking forward to hearing back from you, thanks!

Did everything on the list, it didnt work… the errors are same as before [link text][1]

96481-rgbshooter.log (15.6 KB)

If you completely remove that static mesh, and take out any references in your project to that static mesh, does that get rid of all of the errors? It very well could be your static mesh causing the problem, and may need to simply be reimported or recreated.

Can you upload that static mesh for me?

Let me know.

I have already tried to package the project after removing the static meshes… the result is the 2nd log that I submitted

I uploaded my whole entire project in my initial post, but i’ll upload just the static mesh

[link text][1] (79.8 KB)


I was able to package and run the packaged version of a blank project and the static mesh provided. I created the blank project without any starter content, so only the mesh was in the project.

I then downloaded your project that you also provided and packaged it as is, this project packaged without any trouble. However, the executable does crash when you try to open it.

I have deleted multiple files out of your project and still have not gotten the error to go away. Your project works with Launch and with PIE but not after being packaged.

I believe there is something with one of your blueprints causing trouble instead of your actual static mesh. Have you looked into the blueprints referencing that specific static mesh to see if there was anything incorrectly entered?

Hey Espii77,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you!

I just faced this exact same issue. The same errors as you, and the same warnings as you. I finally tried right-clicking on the project .uproject file and did “Generate Visual Studio project files”, which seems to alleviate the issue for me.