Download

The project could not be compiled. Would you like to open it in Visual Studio?

this has happened to me everytime, please help.

The thing it said:

The project could not be compiled. Would you like to open it in Visual Studio?

Running C:/Program Files/Epic Games/UE_4.11/Engine/Binaries/DotNET/UnrealBuildTool.exe MyProject Development Win64 -project=“C:/Users/Ottmain/Desktop/gmaes/MyProject/MyProject.uproject” -editorrecompile -progress -noubtmakefiles -NoHotReloadFromIDE -2015
@progress push 5%
Parsing headers for MyProjectEditor
Running UnrealHeaderTool “C:\Users\Ottmain\Desktop\gmaes\MyProject\MyProject.uproject” “C:\Users\Ottmain\Desktop\gmaes\MyProject\Intermediate\Build\Win64\MyProjectEditor\Development\UnrealHeaderTool.manifest” -LogCmds=“loginit warning, logexit warning, logdatabase error” -Unattended -WarningsAsErrors -installed
Reflection code generated for MyProjectEditor in 26,8722025 seconds
@progress pop
Performing 7 actions (2 in parallel)
[2/7] Resource PCLaunch.rc
PCH.MyProject.h.cpp
[3/7] Resource ModuleVersionResource.rc.inl
MyProject.generated.cpp
MyProjectGameMode.cpp
C:\Users\Ottmain\Desktop\gmaes\MyProject\Intermediate\Build\Win64\UE4Editor\Inc\MyProject\MyProject.generated.cpp: error C4599: ‘/IC:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\INCLUDE’: command line argument number 248 does not match precompiled headerC:\Users\Ottmain\Desktop\gmaes\MyProject\Source\MyProject\MyProjectGameMode.cpp: error C4599: ‘/IC:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\INCLUDE’: command line argument number 248 does not match precompiled header

MyProject.cpp
C:\Users\Ottmain\Desktop\gmaes\MyProject\Source\MyProject\MyProject.cpp: error C4599: ‘/IC:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\INCLUDE’: command line argument number 248 does not match precompiled header
-------- End Detailed Actions Stats -----------------------------------------------------------
ERROR: UBT ERROR: Failed to produce item: C:\Users\Ottmain\Desktop\gmaes\MyProject\Binaries\Win64\UE4Editor-MyProject.dll
Total build time: 1424,22 seconds

I hope to see your helpful comments

Hi! BudgetTechie

Fast fix:
Open Engine\Source\Runtime\Core\Public\Windows*WindowsPlatformCompilerSetup.h*

remove from line ~28 only 4599!:
#pragma warning (error: … 4599)

or add at the and file:
#pragma warning(disable:4599)

**But more correct install VS2015 UPDATE 3!

Hope this helps!**

Thank you! going to try that.

4599 is on line 29 and i added disable, still nothing
EDIT: i misread it a little… i added disable and deleted other numbers other than 4599 and it worked