"the project could not be compiled" error with UE 4.10.1 but not with 4.11.0


so I’m doing a tutorial but everytime I want to create a C++ project I get this error message:

I’ve got Win7, UE 4.10.1 and VS 2015. Previously I had VS 2013 installed but I uninstalled it before installing 2015. The strange is that when I try the same thing with UE 4.11.0 preview version everything works. I already did a bit of troubleshooting of which I appended the screenshots. I’m grateful forr any help and please tell me if I forgot any info.

Hello ,

It seems like walked you through most of our basic troubleshooting steps in this situation. Another thing I could think of as a possibility would be that there may be issues related to your windows username / folder names. Be sure that your username / project name or any other folder names don’t contain any special characters. UBT (Unreal Build Tool) doesn’t work well with these. Special characters can include anything that isn’t alphanumeric, such as @ or %. Some German characters or characters specific to other other languages such as ß can also be considered special characters.

My username doesn’t contain special characters and as far as I can tell neither the folders UE uses. Could there be some folders that are not obvious to check?
But if that would be the problem should the error occur in Ue 4.11.0, too?

It most likely would, but it is best to rule out any possibilities. Something I noticed that was never clarified, are you getting your build of the engine from the Epic Games Launcher or building it from source that you got from Github?

Thank you for that. To ensure that you are removing everything relating to the engine when you go to reinstall, have you tried using the ‘Remove’ feature inside of the Launcher and then navigating to Users*usernamehere*\AppData\Local\UnrealEngine and clearing out the files relating to that version there? If you cannot find the AppData folder, you can have it appear by opening the Run command from Windows’ Start Menu and typing in %appdata%

I got every build from the Launcher.

I hadn’t tried deleting the folder in AppData. But sadly that didn’t work either and resulted in the same error.

I hadn’t tried deleting the folder in AppData. But sadly that didn’t work either and resulted in the same error.


After one reinstall I had this error:

It says “Installation failed … Make sure your OS is up to date.” but after verifying the UE4 installation it didn’t reappear.

It seems that you’re using Visual Studio 2015 Update 1. I was unaware until a few moments ago but Update 1 is not supported for 4.10.1. You should be able to compile without an issue if you remove this update. I don’t have experience uninstalling these updates so there may be a way to uninstall just the update, but if not you may need to reinstall VS2015 completely and refrain from applying the update.

Weird, the instructor of the course uses VS 2015 with Update 1.

I’ll still try it though.

here… that’s really interesting to know! Thanks for uncovering this for us.

(And to be clear: I’m not the instructor, just trying to lend a hand where I can.)

So I finally got around to try and install VS 2015 without the Update (the ISO version from the website) but it’s still the same error.
Anything else I could try?
The engine version is now 4.10.2 though.

Hello ,

I’m sorry to hear that you’re still having these issues. I have found something else to test in the meantime since we last spoke however. To make sure, the error you’re still having is the one in the first image in your original post correct? If so, follow the steps at the following link about Environment Variables to make sure that your Environment Variables are set up correctly in Windows.

To be safe here’s a new screenshot:

As far as I can tell the Environment Variables seem to be OK.



Could it be a problem that there are leftover variables from older versions? Or that the Windows Kit has version 8.1 (there’s also a folder “10”)?

I’ve never seen this be an issue, but it could possibly be due to your 110, 120, and 140 COMNTOOLS being on separate drives. Would it be possible to reinstall them on the same drive? Preferably the E:\ drive if Visual Studio 2013 was working correctly for you in the past.

We haven’t heard from you in a while, . Are you still experiencing this issue? If so, have you been able to try the possible fix in my previous comment? Please let me know the results of this change. In the meantime I’ll be marking this issue as resolved.

Hi, sorry that I’m only answering now. It’s still the same (not working on 4.10.4) but I didn’t get to try trying your suggestion.
For now I’m just using the preview version of 4.11 until the final version gets released. I’m still at the beginning of learning Unreal and C++. I’m pretty sure that by the time I’ll need an reliable version 4.11 will be out.

But still thank you very much for all the help!