"The prerequisites for unreal engine failed to install"

I have just finished installing Unreal Engine 5.1 and it’s giving me this error. “The Prerequisites For Unreal Engine Failed To Install.” Error Code: LS-0019-IS-PQR5

I heard this might be something related to Visual Studio. I have Visual Studio 2010, 2013, Visual Studio Express, and Visual Studio Code. All of them are unused and expired.

I do have Visual Studio 2022 and it works perfectly fine. Maybe the problem was because it was directed to an older version of Visual Studio on my computer?

Other than that, I tried relaunching several times. Even checked to see if my computer was up-to-date.

Any solutions? Thanks.

2 Likes

There’s a few things you can try here (first I’d try is running as admin):

1 Like

AFAIK UE5 doesn’t support versions of visual studio before VS2015 (included), so I doubt that it recognize the old versions that you have installed.

Did you select all the recommended packages in the visual studio installer 2022? (like game development C++, net framework and other stuff?)

1 Like

HI, I tried everything you listed, however, nothing works stills.

I’m actually not sure. Perhaps I should reinstall or modify it?

1 Like

These are the individual components that I have installed

In the workloads section I only have “Game development with C++” selected so the problem shouldn’t be there, try to modify the install and see if anything changes.

Another thing you can try is to update Latest supported Visual C++ Redistributable and reboot your PC

I tried “most” of the settings you’ve provided. Nothing changed… and also these cost a lot of storage and I have heavily running out of free disk space. I think UE5 is using a different application than Visual Studio 2022.

I just had to reinstall windows a few days ago, I installed VS 2022 and it has been working well for me.

Maybe do a full uninstall and re-install. Make sure to include the .NET (c# etc) option and c++. There is also an option to include game support, there is one in that section that includes unreal - make sure that is ticked. With those options it shouldn’t take too much HD space.

Hi, I somehow managed to fix it now. Adding the -SkipBuildPatchPrereq at the end worked. I tried it before, but it didn’t work at all, but I guess I must have forgotten the close the application fully.

I am very grateful that UE5 Is working for me again. However, I still have a few questions and concerns. First, what exactly are the “Prerequisites” and are they really necessary? Without the Prerequisites, will I lose any features or performance?

Thanks.

1 Like