Download

The node "findPathToActorSynchronously" always return invalid path.

I need help please , the node “findPathToActorSynchronously” always return an invalid object , even if this ennemi can moveTo his location.

I have tried to print the last index of the points array , its always 0,0,0 because the path returned is invalid.

the function getPathLength returns always -1.

If the ennemi can moveTo it’s sure there is a path founded, why this function return invalid?

tried without setting path finding context?

Yes … tried also with all types of context , controller , pawn

Have you tried printf debugging the node itself? Instead of using that Blackboard “Set Value As Bool” node, just printstring “Has Path” or something directly inside that Service? I ask because blackboard values are their own special brand of finicky and difficult to debug, and it’d be silly to spend so much time trying to debug the Find Path node only to find out the issue was with the way the key was being reported to Blackboard.

Thanks for the answer , but unfortunately the key is rightly reported to the blackBoard , i have tried to print the result of the node and its always an invalid object , like if there is no path returned , when i print the last index of the points arrays , its 0,0 ,0

So maybe there is a problem with the path start , the getactorlocation is maybed too high because the NPC is tall , the problem its the same when i set the path start to a linetrace on the ground