Download

The new Sequencer branch or source? One in vr-editor branch crashes.

Hi,

Just got back from GDC. Looked through the branches and the newest Sequencer and the Sequencer Recorder I could find was a part of the dev-vr-editor branch but I have a feeling that isn’t the one I am supposed to be using.

I did the following:

Built it and enabled the plugins.
Created a new sequence.
Created a shot.
Created a cine camera actor.
Added the camera actor to the timeline.
Created a camera cuts track.
As soon as I point the camera cuts track to the cine camera actor I get a crash.

Assertion failed: IsValid() [File:E:\Unreal Engine\UnrealEngine-dev-vr-editor\Engine\Source\Runtime\Core\Public\Templates\SharedPointer.h] [Line: 697]

Thanks!,
Juan Rubio

Hey yankijp,

Could you please open a thread on AnswerHuband include the full callstack and/or log file?
We’ll take a look, thanks!

Posting on there now. I have a feeling though that this isn’t the complete Sequencer/Sequencer recorder that was demo-ed at GDC. Some actors are missing (the camera crane for one). I checked all the other branches and they either are missing the Sequencer recorder plugin and they were last committed in a while ago. I also tried the master branch and I ran into the same issue that someone else I know has that it crashes on shot insertion but like I said that looks to be an older commit of Sequencer itself.