The necessary prerequisites have failed to install. Error Code R-1603

Hello, I’ve been trying since 4pm yesterday to get the launcher working but i keep getting this error, “The necessary prerequisites have failed to install. Error Code R-1603.” So I found this C:\Program Files (x86)\Epic Games\Launcher\Portal\SelfUpdateStaging\Install\Portal\Extras\Redist and inside that i found a file called “LauncherPrereqSetup_x64” and when I clicked on this it gave me this error “0x80070643 Fatal Error during installation”. I’ll attach the log file for that here. Please help :slight_smile:

I should also mention that I’ve tried uninstalling VC2015 x64 and x86, Repairing and reinstalling VS 2015, running it as an administrator, restarting my computer completely, updating my graphics card drivers, making exceptions for it and then completely disabling windows defender. I also noticed that the shortcut was for a Win32 version but when i tried the Win64 version absolutely nothing happened.

Hello PapaZach,

I’m sorry to hear that you are having trouble. Could you please follow the steps here and send me your debug logs and dxdiag? Once we have that information, we can look into your issue further.



Hello again,

Is this your first time installing the Epic Games launcher? In the Windows control panel, under installed programs, do you have an entry for UE4 prerequisites? If so, please uninstall it then try to reinstall the launcher. Reply back with your results.

Also, based on your logs, the launcher is not being run with admin privileges. Please right click on the launcher icon and select “Run As Administrator”.

This is my first time installing and I can’t seem to find the UE4 Prerequisites, I tried to launch it with admin privileges and still get the same error.

try uninstalling all Visual Studio redistribute components from your control panel. Some say that works but I had to go further and uninstall Net Frameworks from there too. This got me unto the launcher and now I am trying to install via the launcher. But after the long install it failed with error 1223. Just tried launching after that and it did eventually get through so all good here.


We have recently updated the launcher to address some of the prerequisite issues. Please see the accepted answer to this post for the steps to follow.

If this does not resolve the issue, please post back and keep us updated.

Hi PapaZach,

We haven’t heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you’re still experiencing this issue, please try the suggestion that I mentioned above then post back here with the requested info.

If you need anything else, feel free to ask.

I AM WITH THIS PROBLEM MAKES ONE WEEK, “0x80070643 Fatal Error during installation”, PLEASE HELP ME !!!

ESTOU COM ESSE PROBLEMA FAZ UMA SEMANA , “0x80070643 Fatal Error during installation” , POR FAVOR ME AJUDEEE !!!

I would like to add that when I repair the launcher, after it is installed, it goes down the updates after that from the error.!