The manifest file is broken + CodeWorksForAndroid + Mac

Hello there ,

I’ve installed UNREAL Engine 4. And as part of UE4, and to build to Android it suggest installing “CodeWorksForAndroid_1R5.dmg”.

But when I run it, I get error saying “The manifest file is broken”.

Can you please suggest a solution for this?

Kind Regards.

Hmm. I just did that last night and it worked fine. I suggest:

  • Make sure you’re on 4.14.3 which was just released.
  • Check that your Android option is selected in the launcher

121498-screen+shot+2017-01-10+at+12.49.18+pm.png

  • Verify your installation

121499-screen+shot+2017-01-10+at+12.49.59+pm.png

  • Try it again.

Hi,

I use a macbook and I was unable to get the codeworks installed for android, In my case I got a ‘golang’ error and I had no clue how to fix it.

In the end, I ended up installing Android SDK, NDK, ant and Java 8 on my own and got it to work. I merely pointed to my custom install in the Android SDK settings in UE as in the pic. I made sure android installation was working by setting up the android studio first before using UE4. See if this works for you.

Thanks
d0d0

Change your SDK API level to “latest” and change the NDK API level to “android-21” without quotes. Upload your full error output log if you run into another problem.

Thanks!

This solution did not work for me. I upgraded UE4 from 4.14.2 to 4.14.3, but still didn’t work.

If your outcome differs than what is provided in this post, you may want to open your own AnswerHub thread and post as much information as possible. Please include your Android SDK settings as a screenshot and any logs as a .txt file.

Thanks!

Don’t use the CodeWorks installer shipped with UE4 but the one from NVIDIA Game Development Tools, SDKs, and Partner Engines | NVIDIA Developer. That worked for me.