The Launcher gives Code: 1 error everytime

as mentioned in this topic!/page8 the launcher isn’t working properly for me. Everytime I try to download anything i get:

“Install Failed Could not download
installation information. Please try
again later. Code: 1”

It happened with the engine (4.8.1 & also 4.8.2), with the substance plugin and with everything else…
Tried everything from here: A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums

Added an exception in the win firewall for the launcher.

Changed my DNS

Added -http=wininet to the launcher just in case

After some attempts the download finally starts but then it downloads for like 30 seconds or so at maximum speed and then it drops instantly to 0b/s and stays there for minutes.
Got me like 4hrs+ to download the engine because of this…
My max speed usually is 2mb/s and now i’m trying to download again to generate the debug log. After 4 or 5 attempts it finally started downloading… but at the surprisingly speed of 50kb/s ±. And of course it dropped back to 0b/s

Here’s the log: (compressed on rar because it was huge to upload it as is) LINK

  • Uploaded it to driver because couldn’t attach a .rar, it’s considered as “invalid”.

Thank you very much for your time and for your help.

Hi Meguido,

Thank you for trying the troubleshooting steps first and uploading your Debug Logs. I’m unsure of what is causing the issue at this point so I am going to ask our Launcher team to investigate further. They may post here with questions or suggestions as they have them.

Hey TJ,

Thank you for answering and yeah no problem with that. I’ll try to answer the questions they do to me :slight_smile:

No answer yet? I’m still having this issue and is really a pain, i can’t download anything from the learn tab for example…

Hi Meguido,

Sorry it’s taken a while to get back to you [your log is pretty big ;)].

Looking through it you seem to be getting a lot of “Failed to download chunk” reports, about 101 by my count. The first thing we need to do is work out whether this is an issue with the Launcher or the connection to the internet.

When one of these errors occurs, it also spits out to the log the URL of the chunk it failed to download, e.g.
These can be pasted into your browser of choice and download there too.

What I recommend trying is: attempt to update the engine version again, and take a look in the log that generates for these reports and randomly try a few of them and number of times in your browser and see if that can download the chunk instead. If the browser fails to download it too, then it might be an issue with your machine, router/modem, or even ISP. If the browser downloads the files fine, then we can start digging further.

Please let us know either way, thanks.


Thanks Andrew for your help,

I’ll be trying that asap.
I’ll let you know how it goes.

Hi Meguido,

Did the suggestion that abrown provided above work for you?

I was just about to post about it. I’ve been unable to try and download the engine again (not so much free space on my hdd right now to download that many gbs). But right now i just opened the Launcher and it started an update and got the some problem with the updating process.
But i think there’s no log for that update, am i right?
In the next few days i’ll try to free up some hdd space and try what abrown suggested.

Hi Meguido,

We haven’t heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you’re still experiencing this issue and the above fix doesn’t work for you. Post back here to reopen this report.



Ouch! just was waiting for today (the release of 4.9) to try it out.
And keeps happening. At first i thought it was fixed by itself (something in amazon’ servers perhaps?) but then again got the 0b/s speed. Tried what abrown suggested and yeah i can download the chunks in the browser without a problem…
So what’s next?

Hi Meguido,

Just to keep you in the loop I am currently investigating whether we can improve your download speeds by altering some values used by the HTTP code. I will be getting back to you soon hopefully with some tests for you to try.

Hi Meguido,

We have a theory that you’re timing out while trying to connect to our servers, hopefully increasing the timeout values for your http module will mean you’re less likely to timeout.

Can you try going to your BaseEngine.ini:

The BaseEngine.ini can be found under Epic Games\Launcher\Engine\Config.

Then changing the following fields to these new values:

Then go to Epic Games\Launcher\Portal\Config and open DefaultEngine.ini.

Inside update this value:

These values are roughly double the current default, you can try tweaking the values higher or lower to get the best results.

Unfortunately this is unlikely to improve your overall speed, however it should mean that the download is much more likely to complete.

Let us know how it goes.

Hello Barnabas!

Thank you for your help. Tried that and I’ve been anle to download without getting any error or having to retry the download. Also dunno why but got No 0b/s speed in the entire download.

I’m really happy now! ^^

Thats great news, glad to hear it :slight_smile: