Download

The Epic Games Launcher is very Unnecessary

Hi Guys.

Im a new user and was looking forward to the UE4 experience especially coming from a visual effects background. I went to your website and was taken back a bit when I realised I had to download a special installer in order to get or install the unity engine. ok fine… I did this and installed an App called Epic Games Launcher. huh!! ok kool… the Launcher installed no problem but that’s as far as not having any problems went.After that …PROBLEMS !!!

I tried so many things and visited many blogs before this thing installed Unity Engine… it took the best part of a week… in order for your Epic Games Launcher to stop verifying the install to death I had to manually transfer the downloaded files from the Engine 4.9 folder into the Launcher Folder. Funny enough as I did this the Epic Launcher was verifying … for the millionth time. when suddenly it said Launch Engine!!! yeahhhh finally its all downloaded and installed… no more problems… so I thought … I was dying to see how this engine performed on my pc " i7 4.8GHz 16GB Ram 2xSSD 2xQaudro 4000 cards and dual screens" so I downloaded the Matinee demo and was blown away… I really was. im now desperate for more demos so I proceeded to to try and download every demo and example that was on the learning tab. this is every users nightmare especially one as enthusiastic as me. the dam Launcher crashes every time you click the “FREE” button. it doesn’t matter which project or demo. you can feel my pain right!!! I only have the matinee demo … played it to death already… all the links that take you to your main website work fine… but the links that takes you to all the good stuff don’t!!! what a wind up!!!

So my question is this. Why have a Epic Launcher at all … its more like an Epic Blunder. it serves no real purpose other than to make the obtaining of the good stuff as difficult as possible and since most of the links take you to your Main site anyway it begs belief why you bother to have a Launcher in the first place… its just providing folks with links to your Website. considering your installation isn’t complex why not just provide us with a simple link on your website so we can just download the thing … provide us with simple instructions on how to install the engine or even better still just make a installer for the engine and forget this silly Epic Launcher thingy… its non productive and a bit **** not to mention long winded.

Kind Regards EU4 Team

I can only assume this troll post, unity engine? EU4 Team? welp the Launcher is bit derp and my only issue is the market place in it is a bit broken.

The launcher is fine as long as it works correctly, it’s a way of keeping track of updates much more easily than a website but ultimately you shouldn’t be having the issues getting UE4 installed.

Also, I would like to point out that your GPU will be an issue–UE4 can only use a single GPU, and in your case you have Quadros which aren’t designed to run games very well, so you may run into some issues due to that.

The launcher is a great tool to have, it makes finding your projects a very simple and quick process, as well as that of retrieving updates. The problems you are encountering are not normal, and the launcher runs fine for me. Also like Darth mentioned, UE4 can only utilize a single GPU, and yep, Quadros are not meant for gaming.

Launcher’s fine, it just sucks having it pop up when I open a project from a folder manually. Sure I can rename the binary, but I don’t want to do that every update.

If a launcher keeps finding problems with the engine download/install, then your machine is not working right.
Either you have bad RAM, a bad drive, bad connectors, or some malware that changes files on disk.
If you have to spend “a week” trying to download the launcher and then having it download the engine, then you’re unlikely to make much progress on building a complex piece of software like a game. It’s one of the most streamlined experiences I’ve seen for downloadable software for PCs.

Also, the launcher is needed for Epic, because without that ability to push their content and marketplace to users, they couldn’t make Unreal Engine free to download.

Finally: “Unity” and “Unreal” are different engines made by different companies.

only one thing i hate about launcher, is renaming it to launcher.bat every time when it updates, so launcher doesn’t start automatically when i open any project.
oh, three things, “downloading stuff almost there” and 2 gigs used on my C drive full of marketplace pics and stuff, basically a cache.

The launcher is actually pretty nice.
If you really don’t like it… Build UE4 from the source!
Because if you use Linux like me… You really begin to appreciate this thing.

But it could use some improvements.

What a silly thread. The launcher is very helpful… however…

The launcher has been updated and now it hangs when scrolling down to see what’s new in the marketplace. This is very annoying and a backwards step.
I usually log on each day to check out new stuff but this has really put me off, I just scrolled down and had to wait for all the thumbnails to load before being allowed to scroll any further. This also happens AFTER I have scrolled all the way down once and the thumbnails should have been cached.
It has taken me over 3 minutes to get to the bottom of the marketplace content because of the hangs and waiting for thumbnails to load.

Hmm, I’ve had no problems at all. I can’t find the Substance plugin in the market place with the launcher, but I found it on the website. That was my only real annoyance with it.

Halfasix, I’ve been wondering the same thing myself. Why do I need a launcher at all? Why isn’t there a link on this site to download an executable to install this software, especially since this is a known issue for so many users? I’ve tried installing this on both Mac and PC, and I can’t get either one to work. On the Mac, I get the “Connection to the server failed” error. I tried creating a new login with a different email, but got the same error. With Windows 10, the launcher won’t launch at all, even if I start up as the administrator. I’ve tried the " -http wininet" thing, but to no avail. When I double click either the shortcut or the executable, it I get a wait cursor for about three seconds and then it crashes.

All I want to do is install the software. How hard is it really to put a download link on a website??? If you intend to make money on anything I develop, this would seem to be a bad business decision as I can’t develop anything without a copy of your software. A download link would solve everybody’s problem, at least until they can debug this launcher. The fact that I’ve had to waste my valuable time trying to get this thing to work says that this problem isn’t being taken seriously enough.

How long are we going to dance around the perfectly obvious? The launcher doesn’t work!!! If this many of your users can’t use it, then face the fact that the thing is broken and implement an alternative solution so that your users can get back to work making you money. As a user, I shouldn’t have to type in " -http wininet", bypass my firewall, turn off my virus protection or really anything to get this to work. All I should have to do is type in my username and password, and sign in. That’s it. It should work and it shouldn’t suck. Why is it my job to fix their launcher? I’m not getting paid for it, but they’ve got everybody here wasting their personal time doing the work of fixing their broken launcher. As the owner of a software development company, I think this is a terrible way to do business but a fantastic way to lose money. Every day I can’t make software is a day this problem is costing the company money. If it were my company, I’d get that download link up immediately, if not sooner.

Hi Valerii,

I’m sorry that you are having such issues with the Launcher, and if you wish for assistance in investigating the root cause of your issues you can make a post on the Installation & Setup section of the UE4 Answerhub.

However, you have another option so you can still access the Unreal Engine 4 without needing to utilize the Launcher. It requires a bit more setup, but you can download the source code from Github and compile it yourself. Here’s instructions.

I have had no issues with the launcher…