Download

The Details panel for items in the content browser is bugged for me, please help

Hello,

I have posted this as a question on AnswerHub but didn’t get any advice so I thought I’d give the forums a try. I would greatly appreciate any help that anyone can give me!

While working on a project (specifically after importing an .obj file that I had created - although I do not think this is actually relevant to the problem) the details panel in the editor broke for me. The panel is still present, but it is not populating with anything. I will post a screenshot of what I am referring to. The panel is only broken for objects in the content browser. If I select a scene item in the outliner, the details panel functions as intended.

Here is some additional information about what I have tried and observed to resolve the issue so far:

  1. I have closed the panel and re-opened from Windows > Details > Details1, Details 2, Details 3, Details 4 but it didn’t help.
  2. I have tried several different engine versions. My project was created in 4.19 but I tried 4.20, and earlier versions as well, but the problem persists across all of the versions.
  3. I tried uninstalling the engines and the Epic Games launcher completely, and reinstalling on a new hard drive to no avail.
  4. Finally I have done all of this using not only my existing project, but with brand new blank projects as well as the provided template projects.

I’m really not sure what to even try next

It’s normal, there is no detail by just selecting something in the content browser.

The Details Panel is for the selected Actor in the World, not in the Content Browser. The Content Browser has an additioanl Editor for several Asset Types.
Double click Meshes a new window will open for example.

Thank you for the responses :slight_smile: I feel like I might be losing my mind. However, I swear it used to function so that, lets say, I clicked on a mesh in the content browser - the details panel would populate and I could drag over a material onto it. I know this can be done by opening the mesh up and doing the same thing in the popup window, it was just a little faster and easier to have direct access sometimes. It is possible that I am experiencing some mix of crazy + lack of experience! At any rate, I really appreciate you guys taking the time to respond, thanks again!