The character doesn't move after i hit retry

Hi,

My game opens with a main menu, there you can start the game.
Everything runs smoothly, I use the “Open Level” node.

But when i die and i press retry or i go back to the main menu, and the load the level again, the player won’t move.

Any ideas what the issue could be?

Thank You !

2 Likes

Hey @Shadow456786! Welcome to the forums!

To get things started, it’s a bit hard to tell what is going wrong with what you have provided. Would you mind sharing your blueprints/code? Especially those related to the player death.

Any additional specifics and information you can provide will be a big help in solving your problem!



Her is the blueprint from death player and the main windget

Hey @Shadow456786,

So where do your parameters reset? Do you have a place where you set Isdead to false? How are you intending to reenable movement? I highly suggest using SetMovementNode like in this thread:

I hope the above points you in the right direction!

I don’t want to be rude but I didn’t really understand what I had to do, I’m a beginner and I don’t know everything, I apologize

Hey @Shadow456786,

It’s okay, you don’t have to know everything, this is just based on what you have already done in your blueprints. What part are you struggling understanding? Specifics will help narrow down what needs to be explained better. Here is an image that helps make clear what was being referred to in the previous post.

Any specifics you can provide will be a big help!


Here is used !






This is all blueprints what i use!

Hey @Shadow456786,

After going through your blueprints, when you die, you disable all movement using the DisableMovement node. If your character is persistent, it never gets that movement back because it doesn’t just reset.

When your level restarts you can re-enable the movement of your character with the SetMovementMode node. You can find more information on that node here:

I hope the above points you in the right direction.

Hello, sorry for bothering you so much, I just don’t know where to put setmovementmode, I tried in several places to replace disable mode with set movement mode and nothing !

Hey @Shadow456786,

You would not be replacing Disable, you would be adding set movement mode. So, for example, you would set the movement back to true after you switch to UI only (if you even need to disable movement before going to UI only), or right when you start your level. Could you share how in your blueprints you have been trying to implement this?

Also, you are removing your movement and disabling movement to your character by using set input to UI only, do you need to do both? Does it work if you remove disable movement? If so, you can just set up your input mode instead. Here is a non-Epic affiliated video on how to do so:

I hope the above points you in the direction you are looking for!

Hi @Shadow456786,

Are you using SmartPoly’s Zombie tutorial?
If so I believe i know where your problem is!

In BP_FirstPersonCharacter go to where you create the main menu widget add the following.


As you can see i have added a “Set Input Mode Game Only” at the end. I think somewhere in the UI Panel we set the input mode to UI only and we dont switch it back upon retrying.

Hope this helps!
Did you ever add anything else to the Zombie Game after finishing the tutorial?

2 Likes

It went exactly as you said, thank you very much!

Thank you so much :sparkles: