"The Android App Bundle file was not signed" / gradle error

Hello :slight_smile:

I’m about to launch a test version of my mobile game on the Play Store but I’m having this error when uploading my .aab on the Play Console : “The Android App Bundle file was not signed”.

However, I do have generated a key via Android Studio (I also did this via the cmd prompt), I have put the key inside the “Build/Android” folder of my project, and information below “Distribution Signing” are correct.

But… I still have this error :eyes:

I don’t know if it’s related, but when I build without activating the “For Distribution” option, I have no problem to make a build.

But when activated, I have this error : “cmd.exe failed with args: […] Intermediate\Android\gradle\rungradle.bat” :app:bundleRelease".

Any suggestion? :smiley:

Thanks a lot!

have you stored your key store (and key alias if any) in the /projectfolder/build/android folder?


have you filled distribution signing fields in android settings?

Yes I did ^^

wait rungradle error?
try deleting the folder /project settings/intermediate/android/armv7/gradle and try building again.

It didn’t work :frowning:

sigh :frowning:

Don’t know if it’s normal, but I have 3 times the “gradle folder” that are automatically created when I build:


I work for an armv7 device and I have


not intermediate/android/gradle here

What’s the difference between armv7 an arm64?

Can It be the source of my problem?

armv7 is 32 bits (older architecture for older devices and not supported by UE5)

1 Like

Oh man I solved my problem. I’m just so dumb.

I have followed a tutorial in which the guy named his key “MyKey”, and at this time I named mine “Herlehos”.

But in Unreal, I wrote “MyKey” instead of “Herlehos” :clown_face:

So now, it is supposed to work. I just have a new error on Google Play console about API but I guess (I hope) I can easily fix that :smiley:

Thanks for your help anyway!

1 Like

:rofl: happy to hear you solved it!

Just a quick question if you have time before I break everything:

The error about API is telling me that my app is made for API 21 and that I need to update it to API 30.

Does that mean that I need to install a new SDK version, re create a NDK and everything else?

Or is it just some parameters to change in Unreal?

Thanks a lot!

this are the settings I am using:


I am not an expert… also had a hard time making it work

1 Like

Yeay it worked!

Thanks a lot ^^

1 Like

Hi, sorry for bothering you, but I have another little problem :stuck_out_tongue:

Maybe if you have time, you could help me on this topic: Android IAP and Ads ?

Thanks a lot ^^

Hi! I’d love to help you but I have never implemented any ads system into my games so is possible you know a lot more than me :slight_smile:

Oh okay!

And for In App Purchases? :smiley: