Download

Textures loading only on very camera position

Hi,
I have a little issue with textures loading. Generally textures are in very bad quality but if I move camera very near to object texture is loading and looks good. This problem doesn’t exist on objects from sample content from Epic packages, so it’s problem with my meshes / textures but which one?

I recorded it and you may look at this:
https://youtube.com/watch?v=J8mAYDBRwFo

Thank you.

Regards,
Patrick

I have the same thing with mine. Would like to know whats the cause of this.

One thing is that I have to scale my meshes up using the loader (for some reason selecting mm as scale from the fbx exporter in max still produces tiny meshes). I can’t seem to find any setting for texture LOD’s that would make this effect apparent. Interesting to hear about the existing unreal content though, might give me a clue on what to search for.

Probably this link helps you: https://forums.unrealengine.com/showthread.php?1727-Blurry-Static-Mesh&highlight=blurry+textures

Also take a look at the mip maps, those are probably causing your issue (in the texture editor)

I have similar issue, checked mip maps, they look ok, sometimes it magically corrects itself, just after opening and closing texture editor (without any changes).

I’ve noticed that I don’t get the blur if I don’t scale the model in the model settings, so I’m thinking this is actually an issue with LOD selection rather than mipmaps.

I did little testing, and changing “Streaming Distance Multiplier” in static mesh settings from 1.0 to ~100.0 for meshes imported with 100+ scale fixed mipmap issues.

It looks like something may be causing the texelratio to be wrong for your meshes. The engine tries to figure out the average texel density on the UV layout to figure out what resolution is needed at various distances. Sometimes this can indicate actual problems with the mesh, such as a hidden group of microscopic polygons. Other times it could be an import/export problem of some kind. I have had to tweak the Streaming Distance Multiplier to be higher on many objects over the years. I usually try not to feel too bad about it, but usually I don’t have to make it 100x higher.

Also sometimes we have to increase the Streaming Distance Multiplier for characters because textures can be so slow to load on console DVDs. So we trick the engine into starting to load them much sooner than they would otherwise have to using this setting. If you are having persistent problems with this I will find the email address where you are supposed to send issues to. Maybe we can get it debugged.

Yes, this could be issues with meshes. Tested meshes were old and with questionable quality. Newer meshes are working as expected. We are keeping eye on this issue and if we find something unusual then we can come back to this.
Thanks for input!

I think i have more info for this issue. This issue still exists and only when meshes are imported and scaled in Unreal Editor (Build Scale). Same mesh pre-scaled in modeling software results in fbx file which in Unreal Editor works perfectly with mipmaping.
Also when two models with same material are in scene (one pre-scaled, mipmaps on other mesh starts working as expected automatically)
When other static mesh actor is removed, it take ~5 seconds and then problematic mesh reverts to “blurry” mipmaps.
example:
aaa277277e0fe2542c71fe5f206fca14042e607d.jpeg <- right mesh is pre-scaled, Build Scale 1.0. Left mesh is not pre-scaled and has Build Scale 60.0
Right mesh removed (after ~5 seconds)
mipmaps_notok.jpg

Thanks,
impc

Bingo! I have the same issue.