Download

Textures imported from Substance Designer look wrong in UE4

tl;dr: When importing textures from Substance Designer into UE4 all textures look too washed out after they have been sampled except for the normal map which looks too dark.

The imported textures themselves look like the ones I export from Substance Designer. However, as can be seen from the attached images, the textures look wrong after sampling.

Most textures appear too washed out:

Except for the normal map which appears too dark:

I have tried exporting as both 8 bit and 16 bit with no difference. All textures are exported as targa in raw format except for the base color which is sRGB.

Strangely, if I turn on sRGB and change the sampler types from linear color and grayscale to color and grayscale the sampled textures look like the imported ones (even though they weren’t exported as sRGB):

I have been looking around the internet and several others seem to be having similar problems, however I have come across no solution that has worked for me.

Any help would be greatly appreciated!

There’s nothing to fix here. The details panel displays all texture thumbnails in sRGB. As you discovered, the material graph displays them with whatever them using whatever their sampler type is set to.

In linear color space dark values are not well represented, which is why colors look washed out. sRGB applies a gamma correct curve to the image in order to remap the range to better represent human vision.

But this is not what you want when storing non-color data, because it is not representing color and isn’t intended to be displayed as-is.

Normal maps are fit to the -1 to 1 range which is why they look darker. Masks/roughness/height and other single-channel non-color data should be set to linear which is why they look “washed out”. Both are expected behavior.

4 Likes

Thank you so much for your detailed explanation! And great that everything is working as it should after all :smiley:

So what would be the correct solution, darken all exports from designer to compensate for how they look in unreal engine? I have similar issue where the albedo exported from designer looks too bright, while albedo generated by same materials designer factory in Unreal looks fine.

In the viewport or in the texture browser? If your scene is too bright in the viewport then your exposure is probably not set correctly, if it is too bright in the texture browser then you probably have sRGB disabled on the texture.

If you have sRGB enabled and it still looks wrong in the texture browser, then your problem is in Substance, not Unreal. Most likely you have the Albedo set to export as linear or raw.

The textures are off in the viewport, and substance designer ones specifically. Only thing so far that fixed it was exporting TARGA and enabling sRBG, or just using factory, but wasn’t sure if it’s the “correct” fixes. Export was set to sRGB.

That is how I export albedo from substance. Eons ago I had some problem with PNG that I cannot recall, maybe it was this…

i confirm this behavior on 4.26.2 on latest ubuntu 20.10… PNG isn’t working here. You’ll have to use targa and ofc then activate also srgb… Nice thanks, it finally looks like it should :slight_smile: