Textures Are Too Bright

Hi there,

I’m new to UE, following this UE5 Tutorial: Unreal Engine 5 Beginner Tutorial - UE5 Starter Course! - YouTube

While following along, I’m noticing my textures a quite a bit brighter than the ones shown in the tutorial. This includes “StarterContent” textures and the ones provided in the video description.

A bit of research has led me to several people encountering this issue in UE4, but no mentions of UE5 so far. Everyone seems to have resolved this issue by exporting their PNG textures as either 8-bit PNG or TGA files. Neither of these solutions have worked for me.

Here are some of the threads I’ve looked at for reference:

I’ve tried (using Photoshop):

  • Exporting as TGA 16 bit & 32 bit
  • Exporting as 8-bit PNG using “Save As” with sRGB
  • Exporting as 8-bit PNG using “Save As” without sRGB
  • Exporting as PNG-8 using “Export for Web (Legacy)”
  • And more (store color profile, transparency on/off, etc)

I’ve noticed this does appear to be related to sRGB. If I turn off sRGB in the texture details, the colors appear correct, however this does not solve the problem as the material seems to require sRGB for the “Color” sampler type.

I’ve noticed if I reimport the texture, it shows up properly, but after saving it immediately goes back to the washed out colors:

After Reimport:
image

After Saving:
image

There is a workaround which I haven’t tried, which is to negate the correction via the material blueprint, however this does not feel like the best solution. Can someone help me find out where I’m going wrong?

I’ve attached the original basecolor PNG so you can try it for yourself as well.

Thanks,
Escius

Looks like I’m not the only one spending hours digging into this issue!

I’m not sure if you’re on an M1 Mac as well, but this is the only thing I’ve found that is relevant to the issue I’m seeing (the same as yours). This article was written on Sep 1, relatively up to date.

Unreal Engine 5 and Apple Silicon Mac M1 - MIRAE.WORKS

Let me know if you’ve found a solution since July?

I am also on an M1 mac. I never found a solution, instead I started working off of my windows desktop. Too many limitations with the Mac.

And UE5 works fine on your PC? Struggling to do anything right on the Mac right now.

I’m now planning to buy a rig just to learn UE.

Do you mind sharing your PC (CPU, RAM & GPU) specs?

Thank you :slight_smile:

Yep, it works fine for me. I was hoping to be able to use my Macbook Pro just for the portability factor, but my PC is handling it like a dream.

It’s a gaming rig I built a couple years back, currently running a i9 9900k, 2080 Super, and 64GB ram. A bit overkill probably if all you need it for is UE, but more power never hurts :slight_smile:

OMG I’m not the only one. I’ve started to go mad, it’s crazy. Everywhere I read about solutions, and nothing worked for me, just like you. I’m on a M1 Mac too.
Holly Molly, this might be an M1 problem then. I love this machine, but with 3D work, your screwed if you’re not on CUDA.

I am encountering this same issue on an M1 Max MacBook Pro as well. I’ve seen this issue on some YouTuber videos of UE5 on M1 Pro: Unreal Engine 5 Ray Tracing Performance On M1 Pro MacBook Pro 14" - YouTube I think the YouTuber doesn’t even know that the materials in the scene are too bright.

I’ve also seen YouTubers unknowingly demonstrate the issue with UE4: Unreal Engine on 14 inch M1 Max – Performance Demo - YouTube

When I compare the Rural Australia scene on my M1 Max to my Windows (RTX 2060/Ryzen5) machine, you can clearly see the issue of Mac being too bright:
Windows:


Mac:

I’ve been trying everything to fix this issue in my MacOS UE5 projects. If you uncheck “sRGB” in the texture files, it makes the texture look correct (not bright and washed out), but it still does not look normal once used in a material (becomes too bright again).

I found one possible, but definitely NOT IDEAL workaround for the time being and that is to change the texture compression method from “Default (DXT1/5, BC1/3 on DX11)” to “Default (DXT5)”.

This problem with this, is that it increases texture resource sizes 4x+, which I don’t think is ideal, especially in the scope of a decently sized project. I’m not sure how less compression would negatively affect a project if every texture is 4x+ larger in resource size. Anyone know the answer to this?

Anyone have some feedback on how to get textures to work properly on MacOS without them looking too bright and washed out, without needing to use the DXT5 compression setting?

It´s being corrected in patch 4.27.2 at least for me is working perfect now.

Before I had to ad a Power 1.97 to my base color and change the tilt V to .9 and I had a close result.

Yeah my 4.27.2 looks right. UE5.00EA2 is still messed up. Hoping this “spring 2022” release isn’t like June 20th.