Download

textures are darker in the viewport but not in material editor

hi there
i have imported mesh and applied texture i created in substance painter but the textures are dark in my viewport but in material editor it is fine
what to do…pls help
47dc58667a1f527d07f01a536003601120492d80.jpeg
28aa0d1f25d27a277dbffe91f34907d7fb8680ae.jpeg

Dont think your viewport is miles away, try adding a sky light, I think that will be enough to fix your issue.

-build your light or set it to dynamic
-make sure that you have a skylight in your scene
-add a reflection capture actor :slight_smile:

Metallic objects need something to reflect so you need to add reflection capture actors

Do these reflection capture actors take up alot of memory resources?
How many of these reflection capture actors can you have in your map before it starts becoming an engine frame performance
issue (If you have alot of metallic objects in your map), like a Sci-Fi City map ect. Or does it act like a simple camera capture
like with a mini-map.

If I’m not mistaken, the reflection capture resolution will be locked to 128 pixels wide (so pretty cheap to render) unless you use console commands to increase that value. You can also go to Project settings>Rendering>Textures - and change the “Reflection Capture Resolution” to a higher value.