Texture streaming leaking performance

I have very strange issue that seems to be related to texture streaming. I have 4km^2 detailed map with much assets (around 65Gb). First fps stays between 40-50fps but when driving through e.g town then suddently I cant look at distance field shadows (from trees) without insane FPS drop. Sometimes it resets to smooth after around half minute but often overall FPS just stucks to poor even returning back to editor. FPS stucks to as poor as when I would have texture streaming off. The bigger poolsize value I have the slower this FPS seem to come. Having bigger memorymargin seem to prevent crashing some bit. I can play only around 5-10min my project with smooth FPS, then need to restart the editor if I want to playtest.

Locations that run 50fps with fresh editor load suddently run only 18fps. The issue also appear if staying in small area while playtesting. The slowdown appear very suddently which makes it feel that some limit get reached and 3d card no longer is able to keep going. Fast camera turning may end in crash (much less now after I started to use mesh instancing).

I have tried to set these values
PoolSizeVRAMPercentage = 0 (was 70)
r.Streaming.PoolSize=5500 (have also tried 4000 and 6000. With 3000 textures wont load)

Is there some other values to change? I would want the texture streaming clean up loaded textures much faster. Currently it looks like the streaming chokes. The used poolsize is very filled all the time.

As additional note, there is 2,3Gb unknown non-streaming textures in GPU memory. I have all textures set to stream and only around 200mb of substance materials. I havent found out what data that 2Gb is. Listtextures dont show that 2Gb too, only textures that I know is there.

I7 5820K, GTX780, 32Gt DDR2400, Win10 64bit

Any advices are welcome. Have been figthing with streaming for months (at least also found out some nice tricks). :slight_smile:

Something happens also when returning to editor from playtest and starting new play. I had long smooth playtest but when starting new one FPS is stucked to low again. Also there is no streaming textures note appearing. Is that texture streaming shutting down?