Texture preview and ingame, on sphere primitive mesh is different

LOD settings i guess. Try disabling streaming on your earth texture.

Preview mesh sphere primitive shows a perfect earth with my earth texture. Just as I would wish it appear in the game.

However ingame it does not appear like in the preview, the texture looks not stretched properly.

I want to make a planet and a drag and drop does not work. It shows perfectly though in the preview window, but not on the sphere mesh in game. Why?

this is what it looks like

Where are the lod settings exactly, and how to disable streaming on a texture?

It says when I build that Material Sphere has overlapping UVs

The sphere mesh you’re using in the game appears to have different UV coordinates. The mesh used in the material editor is /Engine/EditorMeshes/EditorSphere, so try using that one instead.

First I cant find the editorsphere anywhere. Secondly, even if I change the preview mesh to Shape_Sphere.

Delete that. Thanks alot BJ!

I found another sphere shape called Shape_Sphere, which seems to be the editor sphere aswell!

Wow that took a while! Is it even possible to learn this engine? The earth looks great now!